Bug 1834186 - Independent Mode Creation Form Shows Input Fields
Summary: Independent Mode Creation Form Shows Input Fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenShift Container Storage
Classification: Red Hat
Component: ocs-operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: OCS 4.5.0
Assignee: Bipul Adhikari
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 09:29 UTC by Bipul Adhikari
Modified: 2020-09-23 09:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
Independent Mode (white screen) (2.68 MB, video/webm)
2020-05-31 12:13 UTC, Oded
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5241 0 None closed Bug 1834186: Change Input of Independent Mode to Text Area from Text Input 2020-12-16 09:45:03 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:19 UTC

Description Bipul Adhikari 2020-05-11 09:29:42 UTC
Description of problem:
Due to large number of Input fields need to change it to a single text input box.


Version-Release number of selected component (if applicable): OCP 4.5


How reproducible: 1/1


Steps to Reproduce:
1. Installed Operators -> OCS -> Create Storage Cluster
2. Select `Independent Mode`

Actual results: Shows Input Fields


Expected results: Should show text fields


Additional info:

Comment 3 Oded 2020-05-24 17:03:06 UTC
Setup:
Provider:AWS
OCP Version:4.5.0-0.nightly-2020-05-24-072501
OCS Version:ocs-operator.v4.5.0-433.ci


Test process:
1.Go to "Operators" -> "Installed Operators" -> OCS -> Storage Cluster -> "Create OCS Cluster Service"
2.Select "Independent - For external storage"
Result: white screen(need to refresh the web page)

Comment 4 Bipul Adhikari 2020-05-26 15:59:17 UTC
This issue is an OCS Operator issue as the validation JSON annotation coming from OCS is irregular JSON. PR has been raised for that.

Comment 6 Bipul Adhikari 2020-05-27 12:50:18 UTC
This bug has been moved to OCS as the annotation comes from the OCS Operator which was malformed and was breaking the UI. https://github.com/openshift/ocs-operator/pull/519
Fix has been merged.

Comment 9 Oded 2020-05-31 12:11:16 UTC
Setup:
Provider:AWS
OCP Version: 4.5.0-0.nightly-2020-05-30-025738
OCS Version: ocs-operator.v4.5.0-439.ci

Test process:
1.Go to "Operators" -> "Installed Operators" -> OCS -> Storage Cluster -> "Create OCS Cluster Service"
2.Select "Independent - For external storage"
Result: white screen(need to refresh the web page)
*attached screen record

Comment 10 Oded 2020-05-31 12:13:21 UTC
Created attachment 1693831 [details]
Independent Mode (white screen)

Comment 11 Yaniv Kaul 2020-06-25 10:26:08 UTC
Is anyone looking at this?

Comment 12 Bipul Adhikari 2020-06-25 12:22:59 UTC
This issue has been fixed. The OCS Operator which was used to test this did not have the fix in it. Oded can we test this out again?

Comment 13 Yaniv Kaul 2020-06-25 15:31:20 UTC
Missing devel-ack?

Comment 14 Michael Adam 2020-06-25 17:17:56 UTC
(In reply to Bipul Adhikari from comment #6)
> This bug has been moved to OCS as the annotation comes from the OCS Operator
> which was malformed and was breaking the UI.
> https://github.com/openshift/ocs-operator/pull/519
> Fix has been merged.

(1) We shouldn't move bugs from one component that has been fixed to another component if a second layer problem has been uncovered. Instead, we should create a new bug for the new problem.

(2) We should not be moving BZ status to MODIFIED or ON_QA if the bug is not qa-ack'ed. Since QE was already testing this, and moving to FailedQA, I guess it's ok but we need the ACK for the book-keeping. (==> Raz?)

Comment 16 Raz Tamir 2020-06-29 07:20:15 UTC
acked

Comment 19 errata-xmlrpc 2020-07-13 17:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.