This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 183419 - VNC problem when draging icons (desktop disapears)
VNC problem when draging icons (desktop disapears)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
David Lawrence
:
: 186665 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 17:26 EST by David Bentley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: vnc-4.1.1-39.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-26 08:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Bentley 2006-02-28 17:26:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.12) Gecko/20051127 Fedora/1.7.12-1.1.1.legacy

Description of problem:
Remotely connect to computer as normal user (ie machine:2) which has been booted
but has no local login you can run programs as expeccted but when you attempt to drag an icon on the desktop the deshtop disapears and is redrawn with the users
home folder opened on the desktop (ie a restart)

Proved to be a server problem as the result is the same from two compuers one running windows 98SE and one runing FC1

Version-Release number of selected component (if applicable):
vnc-server-4.1.1-35.1

How reproducible:
Always

Steps to Reproduce:
see description

Actual Results:  see description

Expected Results:  normal behavior

Additional info:
Comment 1 David Bentley 2006-03-01 15:09:41 EST
added VNC to summary
Comment 2 David Bentley 2006-03-06 13:53:41 EST
Just wondered has this been forgotten about or will it get fixed post FC5 release.
Comment 3 Jitka Kozana 2006-03-08 12:43:57 EST
It was not forgotten, however I am not able to reproduce your bug (with  
vnc-4.1.1-36)  
    
Please send a step by step description how to reproduce it.    
    
Thank you.    
Comment 4 David Bentley 2006-03-08 14:11:19 EST
Also running vnc-4.1.1-36 here.

vnc setup as follows :-

login as normal user open terminal type vncserver :1
enter desired password
re-enter for confirmation

vnc now running

navigate to .vnc folder and open it and edit the xstarup file un commenting
the two lines suggested to enable a normal desktop.

xstartup as edited

#!/bin/sh

# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

logout as user and login as root

now navigate to /etc/sysconfig/ and edit the vncservers file

vncservers file as edited

# The VNCSERVERS variable is a list of display:user pairs.
#
# Uncomment the lines below to start a VNC server on display :2
# as my 'myusername' (adjust this to your own).  You will also
# need to set a VNC password; run 'man vncpasswd' to see how
# to do that.  
#
# DO NOT RUN THIS SERVICE if your local area network is
# untrusted!  For a secure way of using VNC, see
# <URL:http://www.uk.research.att.com/archive/vnc/sshvnc.html>.

# Use "-nolisten tcp" to prevent X connections to your VNC server via TCP.

# Use "-nohttpd" to prevent web-based VNC clients connecting.

# Use "-localhost" to prevent remote VNC clients connecting except when
# doing so through a secure tunnel.  See the "-via" option in the
# `man vncviewer' manual page.

VNCSERVERS="1:bentledr"
VNCSERVERARGS[1]="-geometry 800x600"

use the services aplet to set vncserver to start at boot save settings now do
restart but don't login.

connect remotely as ipaddr:1
supply the password

the remote desktop now appears and is completely functional except if you
attempt to drag any icon on the desktop all icons dissapear and then re-appear
and the users home folder apears opened on the desktop you can even drag this
folder about OK but if you try and drag any icon within it again results in the
previously described behavior.

the Same is seen from both an fc1 machine and a windows machine.


Comment 5 David Bentley 2006-03-19 14:41:10 EST
If this is still aparent in FC5 final (hope to get it downladed and installed
tomorrow) should this be re-assigned as FC5 or left as devel.
Comment 6 Jitka Kozana 2006-03-20 08:39:04 EST
Tested with FC5. The problem is still here, so I reassigned it to FC5.  
Comment 7 Jitka Kozana 2006-03-27 04:55:03 EST
*** Bug 186665 has been marked as a duplicate of this bug. ***
Comment 8 Jitka Kozana 2006-07-12 07:30:17 EDT
I have tried to reproduce this bug with FC5, vnc-4.1.1-39.fc5, and it was 
working for me.
Please update your system and try, whether the problem still occurs. 
Thank you.
Comment 9 David Bentley 2006-07-26 08:04:56 EDT
I can confirm that all is now OK in FC5 after doing a re-install to test.
The system was running FC6 test1 so when FC6 test2 becomes available I will do
another install and test again (reporting bugs if any found)

Since this was filed against FC5 I suppose it can now be closed.

Note You need to log in before you can comment on or make changes to this bug.