Bug 1834222 - Check for custom console route hostname not to be the same as the default route
Summary: Check for custom console route hostname not to be the same as the default route
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 10:44 UTC by Jakub Hadvig
Modified: 2020-07-13 17:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: User can point the customURL to the same host as the defaultURL of the console. Consequence: Console becomes inaccessible when custom route hostname is the same as the hostname of the default route. Fix: Console operator checks for the duplicate URL. Result: Console is still accessible and console operator should inform about this duplicate issue with a condition
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console-operator pull 426 0 None closed Bug 1834222: Check for custom console route hostname not to be the same as the default route 2021-02-12 10:52:50 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:19 UTC

Description Jakub Hadvig 2020-05-11 10:44:32 UTC
Description of problem:
Console becomes inaccessible when custom route hostname is the same as the hostname of the default route.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to console operator config YAML page
2. Set the custom route hostname to the same hostname as default route uses
```
spec:
  route:
    hostname: <same hostname as default route uses>
```
3. Save changes

Actual results:
Console becomes inaccessible

Expected results:
Console should be still accessible and console operator should inform about this duplicate issue with a condition



Additional info:

Comment 4 Yadan Pei 2020-05-18 05:49:30 UTC
1. Set custom route hostname the same as default console route
$ oc edit console.operator cluster
```
spec:
  route:
    hostname: <same hostname as default route uses>
```
2. Check console-operator log, it will show 'custom route hostname is duplicate of default route hostname'
E0518 05:43:01.341694       1 status.go:78] CustomRouteSyncDegraded InvalidCustomRouteConfig custom route hostname is duplicate of the default route hostname
E0518 05:43:01.341883       1 controller.go:368] console-route-sync--work-queue-key failed with : custom route hostname is duplicate of the default route hostname
E0518 05:43:01.358670       1 status.go:78] SyncLoopRefreshDegraded InProgress routes.route.openshift.io "console-custom" not found
E0518 05:43:01.358824       1 controller.go:129] {Console Console} failed with: routes.route.openshift.io "console-custom" not found
E0518 05:43:03.611828       1 status.go:78] SyncLoopRefreshDegraded InProgress routes.route.openshift.io "console-custom" not found
E0518 05:43:03.612103       1 controller.go:129] {Console Console} failed with: routes.route.openshift.io "console-custom" not found
E0518 05:43:18.077547       1 status.go:78] CustomRouteSyncDegraded InvalidCustomRouteConfig custom route hostname is duplicate of the default route hostname
E0518 05:43:18.077711       1 controller.go:368] console-route-sync--work-queue-key failed with : custom route hostname is duplicate of the default route hostname

3. Visit console route, the default console is still serving correctly

Verified on 4.5.0-0.nightly-2020-05-17-220731

Comment 5 errata-xmlrpc 2020-07-13 17:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.