Bug 1834254 - EventSourceIcon's are dependent apiGroup and version, should depend on Kind
Summary: EventSourceIcon's are dependent apiGroup and version, should depend on Kind
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 12:02 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
topology page (208.52 KB, image/png)
2020-05-14 11:58 UTC, Gajanan More
no flags Details
add page (120.84 KB, image/png)
2020-05-14 11:58 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5379 0 None closed Bug 1834254: fetch eventSource icon based on type and update icon for ping 2020-06-24 02:18:13 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:19 UTC

Description Jaivardhan Kumar 2020-05-11 12:02:58 UTC
Description:
EventSourceIcon's are dependent apiGroup and version, should depend on Kind as we are supporting dynamic Sources now so reference may change.

Currently we detect based on `referenceForModel` wrt to model in codebase, we should rely on Kind as for builtin Sources as well ApiVersion/group may change in future (as we are fetching it from CRDs based on duck type label) but kind would be same.

Update pingSource to use same icon as CronJob

Prerequisites (if any, like setup, operators/versions): Install Serverless/Eventing

Steps to Reproduce:
1. Go to DevConsole -> Add -> EventSources
2. Check EventSource Icons
3. Create an EventSource from built'in and check icon in topology

Actual results: Should show proper icons for each sources and default icon shown for pingSource

Expected results: Should show proper icons for each sources and ping source should show an icon

Comment 3 Gajanan More 2020-05-14 11:58:37 UTC
Created attachment 1688406 [details]
topology page

Comment 4 Gajanan More 2020-05-14 11:58:46 UTC
Created attachment 1688407 [details]
add page

Comment 5 Gajanan More 2020-05-14 11:59:08 UTC
I have validated the bugzilla on
Build: 4.5.0-0.ci-2020-05-13-231257
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshots
Marking this as verified.

Comment 6 errata-xmlrpc 2020-07-13 17:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.