Bug 1834262 - Stand-Alone Duration Component Needed
Summary: Stand-Alone Duration Component Needed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 12:09 UTC by Vikram Raj
Modified: 2020-07-13 17:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5378 0 None closed Bug 1834262: show relative time for pipeline run duration 2020-06-24 02:18:14 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:19 UTC

Description Vikram Raj 2020-05-11 12:09:31 UTC
Description of problem:
When we are showing live duration progress, we are at the whims of the firehose kicks. This can cause our data to not live update, but jump several seconds forward.

Two instances have been recorded, TaskRun Step durations and PipelineRun durations:


How reproducible:


Steps to Reproduce:
1. Navigate to the pipeline page and create a pipeline.
2. Start the pipeline and navigate to the pipeline run page.
3. Notice the Duration of the pipeline run jump several seconds forward.

Actual results:
Duration of the pipeline run jump several seconds forward.

Expected results:
Should show duration in relative time formate.

Additional info:

Comment 3 Gajanan More 2020-05-26 10:01:17 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-05-25-232952
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified

Comment 4 errata-xmlrpc 2020-07-13 17:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.