Bug 1834263 - Status card on storage dashboard is not showing alerts correctly
Summary: Status card on storage dashboard is not showing alerts correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: afrahman
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 12:10 UTC by afrahman
Modified: 2020-07-13 17:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of error (7.28 KB, image/png)
2020-05-11 12:10 UTC, afrahman
no flags Details
ocp_worker_stop screenshot (36.83 KB, image/png)
2020-06-17 10:24 UTC, Yosi Ben Shimon
no flags Details
ocp_worker_start screenshot (20.96 KB, image/png)
2020-06-17 10:24 UTC, Yosi Ben Shimon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5363 0 None closed Bug 1834263: Fixing statuses on dashboards 2020-07-13 14:04:12 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:19 UTC

Description afrahman 2020-05-11 12:10:16 UTC
Created attachment 1687284 [details]
Screenshot of error

Description of problem:
Status card on storage dashboard is not showing alerts status correctly

Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
Easily reproducible

Steps to Reproduce:
1.Install OCS operator and create storage cluster
2. Go to Persistent dashboards

Actual results:
The alerts section reports '0' when no alerts.


Expected results:
The alerts section should be hidden when no alerts.

Additional info:

Comment 3 Yosi Ben Shimon 2020-06-17 10:23:24 UTC
Tested on:
OpenShift Version: 4.5.0-0.nightly-2020-06-17-001505

Deployed OCP on AWS.

At the start, there were no alerts so there wasn't any "0" on the alert section.
Tried to stop one of the worker node (via AWS instances) and waited for the alerts to appear (see attachment "ocp_worker_stop").
The alerts appeared as expected.
Finally, I started that worker and waited for the alerts to be gone (see attachment "ocp_worker_start").
The alerts were gone as expected.

Moving to VERIFIED

Comment 4 Yosi Ben Shimon 2020-06-17 10:24:15 UTC
Created attachment 1697790 [details]
ocp_worker_stop screenshot

Comment 5 Yosi Ben Shimon 2020-06-17 10:24:39 UTC
Created attachment 1697791 [details]
ocp_worker_start screenshot

Comment 6 errata-xmlrpc 2020-07-13 17:37:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.