Bug 183427 - crashes with cx8800 driver / pchdtv card
Summary: crashes with cx8800 driver / pchdtv card
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-28 23:40 UTC by Ask Bjørn Hansen
Modified: 2015-01-04 22:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 02:50:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ask Bjørn Hansen 2006-02-28 23:40:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/417.9 (KHTML, like Gecko) Safari/417.8

Description of problem:
Hi,

With all the Fedora Core 5 test kernels my system crashes when I capture video from my pchdtv-3000 
card for a couple of hours.

Some kernel versions back it'd show some out of memory messages on the screen, but be mostly 
unresponsive.  I tried having the system email me a top output every minute to see if I could catch what 
was eating the memory, but it always showed plenty memory free for cache and buffers.   

The system has 4GB ram.  I tried specifying mem=2048M when booting to see if it would make a 
difference, but it didn't.

The last few kernels just had the system hang (keyboard input didn't work).

I wasn't going to report it with this little information except I tried upgrading the kernel to 2.6.16-rc4 
and haven't had any problems since.  I copied the .config from the latest fc5 test kernel.

The cx2388x DVB driver is the same in the two kernels, so it's not something that simple.


 - ask

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1) start a capture from the pchdtv card
2) wait for the system to hang. 
  

Additional info:

Comment 1 Ask Bjørn Hansen 2006-03-08 00:46:57 UTC
I think this was fixed in 2.6.15-1.2009.4.2_FC5smp (the "raid1 leak" fix in 2008)

Comment 2 Dave Jones 2006-03-08 02:50:35 UTC
cool, thanks for the update.



Note You need to log in before you can comment on or make changes to this bug.