Bug 1834304 - Show dialog when `Edit YAML` link in Pipeline Builder Page is clicked
Summary: Show dialog when `Edit YAML` link in Pipeline Builder Page is clicked
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Debsmita Santra
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 13:43 UTC by Debsmita Santra
Modified: 2020-07-13 17:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Initially, the dialog, notifying the user that on switching to YAML editor all the unsaved changes will be lost, was shown only when values have been entered in the form. Now the user will be notified every time he/she switches to YAML editor irrespective of whether or not values have been entered in the form
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
dialog (112.73 KB, image/png)
2020-05-15 11:30 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5380 0 None closed Bug 1834304: Always show dialog message when `Edit YAML` link in Pipeline Builder Page is clicked 2020-06-24 02:18:19 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:48 UTC

Description Debsmita Santra 2020-05-11 13:43:27 UTC
Description of problem:
No dialog message is shown to the user in the Pipeline Builder Page when there are no changes and the user clicks `Edit yaml` link

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Always

Steps to Reproduce:
1. Click on Pipelines Nav Item
2. Click on `Create Pipeline`
3. Click on `Edit Yaml` link

Actual results:
No warning or alert message is shown to the user 

Expected results:
The dialog message should always be shown when "Edit YAML" link is clicked

Additional info:

Comment 3 Gajanan More 2020-05-15 11:30:24 UTC
Created attachment 1688898 [details]
dialog

Comment 4 Gajanan More 2020-05-15 11:32:14 UTC
I have validated the bugzilla on
Build: 4.5.0-0.nightly-2020-05-15-045750
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the screenshot shared
marking this as verified

Comment 5 errata-xmlrpc 2020-07-13 17:37:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.