Bug 1834345 - `/k8s/all-namespaces/import` in Dev Console results in 404
Summary: `/k8s/all-namespaces/import` in Dev Console results in 404
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 14:34 UTC by Robb Hamilton
Modified: 2020-07-13 17:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-05-11-110006 Cluster ID: de6c9a2c-6321-4ff5-b668-1cf7a8ba200b Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Last Closed: 2020-07-13 17:37:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
404 error (224.89 KB, image/png)
2020-05-11 14:34 UTC, Robb Hamilton
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5392 0 None closed Bug 1834345: Handle import for all namespaces in dev perspective 2020-06-24 02:19:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:48 UTC

Description Robb Hamilton 2020-05-11 14:34:50 UTC
Created attachment 1687356 [details]
404 error

Description of problem:  Changing the project picker to `all namespaces` while on the `Import YAML` page in Dev Console results in 404 error.

Steps to Reproduce:
1.  In the dev console, visit `/add/all-namespaces`
2.  Click one of the existing project links.
3.  Click the `YAML` card.
4.  Change the project picker to `all namespaces`.
5.  Note the 404 error.

Actual results:  404 error.


Expected results:  Import YAML for all namespaces.


Additional info:  The bug is the result of https://github.com/openshift/console/blob/master/frontend/packages/dev-console/src/plugin.tsx#L740.  Note the admin console works correctly.

Comment 3 Gajanan More 2020-06-10 12:29:41 UTC
I validated the bugzilla on:
Build:4.5.0-0.nightly-2020-06-09-223121
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:37:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.