Bug 1834354 - Helm resource tab on topology side panel creates wrong resource links for CLI charts
Summary: Helm resource tab on topology side panel creates wrong resource links for CLI...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Rohit Rai
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 14:57 UTC by Rohit Rai
Modified: 2020-07-13 17:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5386 0 None open Bug 1834354: Fix helm resource link in topology side panel 2020-06-24 02:19:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:37:48 UTC

Description Rohit Rai 2020-05-11 14:57:02 UTC
Description of problem: Helm charts installed using CLI have wrong resource links created in side panel for helm release. The links created are using `all-namespaces` instead of release namespace

Prerequisites (if any, like setup, operators/versions):
Steps to Reproduce:
1. Add stable helm repo in CLI
2. Install mariadb - `helm install maria-test stable/mariadb`
3. Go to the topology and select the release.
4. Click on any of the resources in the list.

Actual results: It takes you to all-namespaces page

Expected results: It should take you to the correct resource link.

Reproducibility (Always/Intermittent/Only Once):  Always.

Build Details:
Additional info:

Comment 3 Gajanan More 2020-05-15 06:24:02 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.ci-2020-05-14-224329
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:37:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.