Bug 1834454 - Regression related to support for multiple IPv6 addresses
Summary: Regression related to support for multiple IPv6 addresses
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnsmasq
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL: http://lists.thekelleys.org.uk/piperm...
Whiteboard:
Depends On: 1829448
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-11 18:16 UTC by Petr Menšík
Modified: 2020-05-29 02:26 UTC (History)
9 users (show)

Fixed In Version: dnsmasq-2.81-3.fc32 dnsmasq-2.80-15.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1829448
Environment:
Last Closed: 2020-05-16 03:39:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Menšík 2020-05-11 18:16:12 UTC
+++ This bug was initially created as a clone of Bug #1829448 +++

According to Harald's email to dnsmasq ML http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2020q2/014038.html there is regression in latest dnsmasq version dnsmasq-2.79-11.el8

Details from Harald:

We discovered an issue introduced in this commit:
137286e9baecf6a3ba97722ef1b49c851b531810

Prior to this commit one could have two dhcp-host entries, one for IPv4
and another for IPv6, for example:

 dhcp-host=52:54:00:bc:c3:fd,172.20.0.11,host2
 dhcp-host=52:54:00:bc:c3:fd,[fd12:3456:789a:1::aadd],host2

This no longer works. In the above example dhcpv6 client succedes, but
the dhcpv4 client get 'no address available'. Swapping the order of the
two entries in the config file allow the dhcpv4 client to succeed, but
then the dhcpv5 client fails.

Alternative configurations that do work in 2.81:

 dhcp-host=52:54:00:bc:c3:fd,172.20.0.11,host2
 dhcp-host=tag:dhcpv6,52:54:00:bc:c3:fd,[fd12:3456:789a:1::aadd],host2

or: 

 dhcp-host=52:54:00:bc:c3:fd,172.20.0.11,[fd12:3456:789a:1::aadd],host2


I'm not sure using two dhcp-host entries was ever intended to work, as
the manual page states that both ipv4 and ipv6 address can be defined
in a single entry.

A first tought for possible fix would be to internally set the
'tag:dhcpv6' for any dhcp-host entry with only ipv6 addresse(s).

It impacts e.g. OpenStack Neutron, see https://bugzilla.redhat.com/show_bug.cgi?id=1829201 for details.

--- Additional comment from Petr Menšík on 2020-05-11 12:25:00 CEST ---

Patch posted to upstream list by Harald[1].

1. http://lists.thekelleys.org.uk/pipermail/dnsmasq-discuss/2020q2/014051.html

Comment 1 Fedora Update System 2020-05-13 10:49:45 UTC
FEDORA-2020-d8a06f82e0 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d8a06f82e0

Comment 2 Fedora Update System 2020-05-13 10:52:26 UTC
FEDORA-2020-29b442f83e has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-29b442f83e

Comment 3 Fedora Update System 2020-05-14 04:31:24 UTC
FEDORA-2020-d8a06f82e0 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d8a06f82e0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d8a06f82e0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-05-14 06:07:03 UTC
FEDORA-2020-29b442f83e has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-29b442f83e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-29b442f83e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2020-05-16 03:39:16 UTC
FEDORA-2020-d8a06f82e0 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2020-05-29 02:26:25 UTC
FEDORA-2020-29b442f83e has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.