Bug 183446 - cal not UTF-8-aware
cal not UTF-8-aware
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-28 23:09 EST by Miloslav Trmač
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 15:03:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2006-02-28 23:09:07 EST
Steps to Reproduce:
$ LC_ALL=cs_CZ.UTF-8 cal

Actual results:
    březen 2006
Ne Po Ú St Č  P So
...

Expected results:
    březen 2006
Ne Po Út St Čt Pá So
...

Version-Release number of selected component (if applicable):
util-linux-2.13-0.16

Seems to work fine after adding #define ENABLE_WIDECHAR to the top of cal.c,
but AFAICS nothing at all in the source defines ENABLE_WIDECHAR (only
HAVE_WIDECHAR).

more, ul, column, pg check ENABLE_WIDECHAR too, I have not checked whether
there are any bugs caused by its absence in these utilities.

Note You need to log in before you can comment on or make changes to this bug.