Bug 1834892 - Prometheus-operator ARCH is hardcoded to amd64
Summary: Prometheus-operator ARCH is hardcoded to amd64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-12 15:29 UTC by Andy McCrae
Modified: 2020-07-13 17:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift prometheus-operator pull 71 0 None open Bug 1834892: CARRY: allow building multi-arch prometheus-operator images downstream 2020-06-24 02:21:29 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:13 UTC

Description Andy McCrae 2020-05-12 15:29:42 UTC
Description of problem:
After 4.4 the ARCH and OS in the Makefile were defaulted to amd64/linux upstream - this means that any multi-arch builds are built amd64 and fail to run successfully on 4.5+

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Consistently

Steps to Reproduce:
1. Build prometheus-operator or prometheus-config-reloader on non-x86_64 machine.
2. Attempt to run the image 

Actual results:

exec format error

Expected results:

The image runs successfully.

Additional info:

A fix is upstream in coreos/prometheus-operator: https://github.com/coreos/prometheus-operator/commit/fcdb5027b58d9dded99fb18bcd2c7b1032ff9e97 but this won't be included in 4.5, there is a PR up already to fix this downstream: https://github.com/openshift/prometheus-operator/pull/71/files

Comment 3 Junqi Zhao 2020-05-15 10:26:47 UTC
LGTM with 4.5.0-0.nightly-2020-05-14-190315

Comment 4 errata-xmlrpc 2020-07-13 17:37:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.