Bug 1834911 - missing tech preview badge for terminal
Summary: missing tech preview badge for terminal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Sahil Budhwar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-12 16:16 UTC by Sahil Budhwar
Modified: 2020-07-13 17:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
tech preview badge on same page (87.51 KB, image/png)
2020-05-19 04:26 UTC, Gajanan More
no flags Details
tech preview badge for terminal new bar (45.72 KB, image/png)
2020-05-19 04:26 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5414 0 None closed Bug 1834911: add tech preview badge to cloud shell 2020-06-24 02:22:00 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:13 UTC

Description Sahil Budhwar 2020-05-12 16:16:31 UTC
terminal (cloud shell) is considered tech preview and was identified as needing a tech preview badge.

The current badge is too large for the header and the pill tags from PF use the same grey background as the terminal header. We need a new color.

steps to reproduce:

1. install the che-workspace-operator to get the cloud shell enabled in the UI https://github.com/che-incubator/che-workspace-operator
2. open the cloud shell terminal
3. Observe: drawer is open with no tech preview badge
4. Expected: tech preview badge in drawer header
5. Now click the button to open the cloud shell in a new tab
6. Observe: new terminal tab open with no tech preview badge
7. Expected: tech preview badge in terminal tab header

Comment 3 Gajanan More 2020-05-19 04:26:25 UTC
Created attachment 1689738 [details]
tech preview badge on same page

Comment 4 Gajanan More 2020-05-19 04:26:40 UTC
Created attachment 1689739 [details]
tech preview badge for terminal new bar

Comment 5 Gajanan More 2020-05-19 04:27:54 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-18-204038
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot
Marking this as verified

Comment 6 errata-xmlrpc 2020-07-13 17:37:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.