Bug 1834963 - Update uninstall operator modal text
Summary: Update uninstall operator modal text
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-12 18:45 UTC by Peter Kreuser
Modified: 2020-07-13 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
remove operator installed on all-namespaces (110.36 KB, image/png)
2020-05-13 09:41 UTC, XiaochuanWang
no flags Details
remove operator installed on one namespace (171.60 KB, image/png)
2020-05-13 09:42 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5417 0 None open Bug 1834963: Update uninstall operator modal text 2020-06-24 02:22:18 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:20 UTC

Description Peter Kreuser 2020-05-12 18:45:39 UTC
Description of problem:
Text in uninstall operator dialog is not the latest from design, and does not entirely convey to the user that custom resources will not be removed with the operator.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Uninstall Operator
2.Note text

Actual results:
"This will remove operator Camel K Operator from all namespaces. Your application will keep running, but it will no longer receive updates or configuration changes."

Expected results:
Design seen here:
http://openshift.github.io/openshift-origin-design/designs/administrator/olm/custom-operator-delete-message/

Both the uninstall text and the heading "Message from operator developer" should match the design. The description text may need to remove word "namespace" now that we sometimes substitute in "all namespaces" for the namespace.

Additional info:

Comment 3 XiaochuanWang 2020-05-13 09:41:53 UTC
Created attachment 1688000 [details]
remove operator installed on all-namespaces

Comment 4 XiaochuanWang 2020-05-13 09:42:24 UTC
Created attachment 1688001 [details]
remove operator installed on one namespace

Comment 5 XiaochuanWang 2020-05-13 09:43:53 UTC
Attach the screenshots for uninstall operators from both one-namespace and all-namespaces. The message is expected now. Verified on 4.5.0-0.nightly-2020-05-13-043728

Comment 6 errata-xmlrpc 2020-07-13 17:37:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.