Bug 1835005 - Portworx Operator - Incorrect mapped "UpdateStrategy" widget on Operand Creation view.
Summary: Portworx Operator - Incorrect mapped "UpdateStrategy" widget on Operand Creat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-12 21:35 UTC by tony.wu
Modified: 2020-07-13 17:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Manifested, discovered, and fixed before release.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:37:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
[portworx-operator]_create_StorageCluster_form (904.29 KB, image/png)
2020-05-12 21:35 UTC, tony.wu
no flags Details
Verification screenshot (83.70 KB, image/png)
2020-05-25 02:51 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5483 0 None closed Bug 1835005: [OperandForm] Only use descriptors to define form widgets 2020-12-21 16:46:43 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:20 UTC

Description tony.wu 2020-05-12 21:35:38 UTC
Created attachment 1687826 [details]
[portworx-operator]_create_StorageCluster_form

Description of problem:
The current "UpdateStrategy" specDescriptor (and UI widget) is for "Deployment" object; however, the Operand of Portworx Operator, "StorageCluster", is managing a "DaemonSet" object.

Console shouldn't auto-apply the existing "UpdateStrategy" widget on Creation Operand view since there could be cases that the CR is managing a "DaemonSet" object, like the Portworx case.


Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
100%

Steps to Reproduce:
1. Go to 'OperatorHub' view and install "Portworx Operator" to a Namespace
2. Go to 'Installed Operatos' view and create "StorageCluster"
3. Scroll toward the bottom of the "Create StorageCluster" view 

Actual results:
"UpdateStrategy" widget is auto-applied on the "Create StorageCluster" view.

Expected results:
Console doesn't auto apply "UpdateStrategy" widget but requires Operator authors to explicitly map it in the CSV file.


Additional info:

Comment 3 XiaochuanWang 2020-05-25 02:51:12 UTC
Created attachment 1691674 [details]
Verification screenshot

Comment 4 XiaochuanWang 2020-05-25 02:52:59 UTC
Now the admin could specify the deployment strategy when creating instance. Please refer to the screenshot in attachment.
Verified on 4.5.0-0.nightly-2020-05-24-191212

Comment 5 errata-xmlrpc 2020-07-13 17:37:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.