Bug 183504 - Clearlooks progressbar display grabled when using r100/r200 based cards
Clearlooks progressbar display grabled when using r100/r200 based cards
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://lovesunix.net/blog/?p=60
:
: 185849 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2006-03-01 11:06 EST by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-04 13:25:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the effect (23.78 KB, image/png)
2006-03-01 11:07 EST, David Nielsen
no flags Details

  None (edit)
Description David Nielsen 2006-03-01 11:06:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060212 Epiphany/1.9

Description of problem:
I'm seeing glitzes like in the attached screenshot when using r100 and r200 based cards and the clearlooks engine. The glitz seems to go away after the progressbar is redrawn but is fairly easily visible in all horizonal progress bars.

Version-Release number of selected component (if applicable):
gtk2-engines-2.7.4-3

How reproducible:
Always

Steps to Reproduce:
1. Run clearlooks using an r100 or r200 based card

  

Actual Results:  2. effects like the attached screenshot

Expected Results:  2. pretty progressbar

Additional info:

This is an r200 based ATI 9250 card, running rawhide as of 01-03-06 on an Athlon-XP 1600+
Comment 1 David Nielsen 2006-03-01 11:07:28 EST
Created attachment 125475 [details]
screenshot of the effect
Comment 2 Matthias Clasen 2006-03-02 08:35:30 EST
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=333128
Comment 3 Ray Strode [halfline] 2006-03-02 12:04:22 EST
This seems more likely to be a driver issue than a Clearlooks-cairo issue.
Comment 4 Mike A. Harris 2006-03-02 12:32:22 EST
Try disabling 2D accel to see if that changes anything.  Also try switching
from XAA to EXA (and re-enabling accel).

Comment 5 David Nielsen 2006-03-02 12:44:24 EST
changing the default to:
Option "AccelMethod" "XAA" doesn't change the outcome.

testing using the lighthouse gtk theme I can't seem to reproduce the issue.

I tested previously with my r300 based card and I didn't see the issue.
Comment 6 Mike A. Harris 2006-03-02 13:25:52 EST
(In reply to comment #5)
> changing the default to:
> Option "AccelMethod" "XAA" doesn't change the outcome.

Right, because XAA /is/ the default.

Comment 7 David Nielsen 2006-03-02 13:32:39 EST
With EXA enabled the problem is still there.
Comment 8 David Nielsen 2006-03-02 14:11:43 EST
Option "NoAccel" "on"

seems to fix the problem, but as expected it's horribly slow
Comment 9 Noa Resare 2006-03-20 09:47:52 EST
*** Bug 185849 has been marked as a duplicate of this bug. ***
Comment 10 Andrea Santilli 2006-04-14 20:26:47 EDT
I not only get a weird progressbar but also random colors on particular gtk2
widgets such as the "New" button in Evolution toolbar. This happens with every
cairo based theme.
I've enabled exa on a Radeon 9000.
Comment 12 David Nielsen 2007-03-04 13:25:29 EST
This seems to have gone away in the FC6 era thus I'm closing it

Note You need to log in before you can comment on or make changes to this bug.