Bug 183506 - xorg-x11-xkbdata-1.0.1-5 breaks keyboard on German-language thinkpad
xorg-x11-xkbdata-1.0.1-5 breaks keyboard on German-language thinkpad
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 11:30 EST by Levin Fritz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 11:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Levin Fritz 2006-03-01 11:30:31 EST
After upgrading to the latest rawhide (as of 2006-03-01) and rebooting, the
keyboard on my notebook did not work right anymore. One of the packages that got
upgraded was xorg-x11-xkbdata (to version 1.0.1-5) and manually downgrading to
xorg-x11-xkbdata-1.0.1-2 fixes the problems, so I guess xorg-x11-xkbdata is the
culprit here.

The problems in particular are:
* Umlauts and sharp-s do not work (if I press the keys, nothing happens).
* Shift does not work for keys other than characters. So Shift-1 makes 1
(instead of !), Shift-< makes < (instead of >) etc.
* AltGr does not work at all. On German keyboards, AltGr is used to enter @ \ ~
and some other characters.

The notebook is an IBM Thinkpad X40 with a German keyboard. The keyboard is a
little unusual in that it has no Windows keys but some special keys (eg, a "Fn"
modifier key and a mute key).

I have the keyboard model set to "Generic 105-key (Intl) PC" and the layout to
"Germany Eliminate dead keys".

I anyone knows where I can find xorg-x11-xkbdata-1.0.1-{3,4} I could try those
and narrow the cause down a bit. Let me know if there's anything else I can do
to help debug this.
Comment 1 Mike A. Harris 2006-03-01 14:39:27 EST
Thanks for the report. We've switched to xkeyboard-config xkb data in the -5
release, and there are a few glitches caused in the transition.  The -6
release adds some backward compatibility symlinks that were missing.

Please update to:

xorg-x11-xkbdata-1.0.1-6 is now available for download via ftp at the following
URL:  ftp://people.redhat.com/mharris/testing/unstable

That'll hit rawhide tomorrow as well, but at this point we need people testing
things as quickly as possible and reporting back right away so we have time
to fix any remaining problems.

You've mentioned 3 bulletted problems in the above report, and hopefully
all 3 will be fixed in the new package, however if there are any problems
remaining after the upgrade, please file individual bug reports per issue,
so they can be tracked individually.

There are various fixes available upstream which I'll be reviewing this
week as well.

Thanks in advance.
Comment 2 Levin Fritz 2006-03-02 10:10:12 EST
xorg-x11-xkbdata-1.0.1-6 fixes all problems I had. Nice work!

Note You need to log in before you can comment on or make changes to this bug.