Bug 183508 - pyuic returns error about undefined symbols
pyuic returns error about undefined symbols
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PyQt (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 11:49 EST by Maxwell Bottiger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 09:03:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxwell Bottiger 2006-03-01 11:49:55 EST
Description of problem:

pyuic will not compile .ui files.

Version-Release number of selected component (if applicable):
PyQt version 3.14.1-1
QtDesigner 3.3.4
Qt-3.3.4-15.4

How reproducible:
Every time 

Steps to Reproduce:
1.pyuic testapp_ui.ui -o testapp_ui.py
2.
3.
  
Actual results:
[bottiger@golbez ~]$ pyuic metric.ui -o metric.py
pyuic: symbol lookup error: pyuic: undefined symbol: _ZN12QDomDocumentC1Ev

Empty .py files are generated

Expected results:
Hopefully a compiled python executable

Additional info:
I have tried a home made qt file from Qt Designer, as well as a .ui file from a
PyQt website.
Comment 1 Maxwell Bottiger 2006-06-06 09:03:29 EDT
It turns out a 3rd party vendor's software contained the commercial release of
an incompatible version of qt, and pyuic was linking the wrong version of the qt
libraries.  This has been fixed, and is not a bug.

Note You need to log in before you can comment on or make changes to this bug.