Bug 1835092 - Use "View pod logs" instead of "View pod overview" in VM status popup window
Summary: Use "View pod logs" instead of "View pod overview" in VM status popup window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 05:42 UTC by Guohua Ouyang
Modified: 2020-07-13 17:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: error popup link to pod overview Consequence: users need to change tab to events, to view pod events. Fix: link directly to pod events. Result:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
pod events link (18.53 KB, image/png)
2020-05-20 14:57 UTC, Radim Hrazdil
no flags Details
pod events (235.68 KB, image/png)
2020-05-21 03:29 UTC, Guohua Ouyang
no flags Details
vm events (253.69 KB, image/png)
2020-05-21 03:29 UTC, Guohua Ouyang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5419 0 None closed Bug 1835092: In VM status popup link to pod events instead of pod overview 2020-06-24 02:30:11 UTC
Github openshift console pull 5506 0 None closed Bug 1835092: pod to Pod 2020-06-24 02:30:12 UTC
Github openshift console pull 5510 0 None closed Bug 1835092: logs instead of events in error popup 2020-06-24 02:30:11 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:26 UTC

Description Guohua Ouyang 2020-05-13 05:42:49 UTC
Description of problem:
Use "View pod logs" instead of "View pod overview" is more direct for debugging, and "Use "View pod logs" should go to pod logs tab.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-12-065413

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-05-13 08:25:51 UTC
Note:
After offline discussion with Guohua we agreed to implement "View pod events" instead of "View pod logs"
Main reason was that logs may be empty on some error cases ( e.g. pod container never come up ) while the evnets will hold debug helpful information.

Comment 4 Radim Hrazdil 2020-05-20 14:57:19 UTC
Shouldn't we use "Pod" instead of "pod"?

Comment 5 Radim Hrazdil 2020-05-20 14:57:59 UTC
Created attachment 1690269 [details]
pod events link

Comment 7 Guohua Ouyang 2020-05-21 03:29:23 UTC
Created attachment 1690467 [details]
pod events

Comment 8 Guohua Ouyang 2020-05-21 03:29:47 UTC
Created attachment 1690468 [details]
vm events

Comment 9 Guohua Ouyang 2020-05-21 03:31:28 UTC
Pod events and VM events looks the same pretty much, so "View Pod logs" should be better for it.

Comment 10 Yaacov Zamir 2020-05-21 04:42:24 UTC
@Guahua, hi,

We discussed that and agreed to use events:
https://bugzilla.redhat.com/show_bug.cgi?id=1835092#c1

Will implement logs than :-)

Comment 12 Guohua Ouyang 2020-05-27 07:52:52 UTC
verified on upstream 4.5 branch, commit 88b7689b0fb3dfc557d9e06dc509952b9233661e.

Comment 13 errata-xmlrpc 2020-07-13 17:38:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.