Bug 1835151 - Error navigating to add page immediately after creating Knative Service resource
Summary: Error navigating to add page immediately after creating Knative Service resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 09:29 UTC by Christoph Jerolimov
Modified: 2020-07-13 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the error message (135.48 KB, image/png)
2020-05-13 09:29 UTC, Christoph Jerolimov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5422 0 None closed Bug 1835151: Fix rare crash in the "Add" page when a service fetch fail 2020-06-24 02:30:15 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:38 UTC

Description Christoph Jerolimov 2020-05-13 09:29:24 UTC
Created attachment 1687997 [details]
Screenshot of the error message

Description of problem (by Christian):
I encountered this error by navigating to the developer perspective add page immediately after creating the knative service resource from the admin perspective installed operator page.

This will probably be hard to reproduce, but we should guard against the following error which resulted in a white screen.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Currently not possible for me (Christoph). It should be done by the following steps.

Steps to Reproduce:
1. Install serverless operator
2. Create a namespace
3. In Administration perspective create a knative service resource
4. Switch to developer perspective and open "+ Add"

Alternative when testing this locally while developing:
1. In frontend/packages/dev-console/src/components/AddPage.tsx change the prop name of one the FirehoseResources. For example change the prop from 'statefulSets' to 'statefulSets_failing'.

Actual results:
A white screen was shown and this message was logged in the browser console:

Uncaught TypeError: Cannot read property 'data' of undefined
  at EmptyStateLoader (AddPage.tsx:41)
  at ...


Expected results:
No error, no white screen.

Additional info:

Comment 3 Gajanan More 2020-05-20 10:22:42 UTC
I tried to reproduce but wasn't able to reproduce it.
I have validated the bugzilla on
Build: 4.5.0-0.ci-2020-05-18-204038
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.