Bug 1835228 - Handle embedded pipelineSpec in pipelineRun details page.
Summary: Handle embedded pipelineSpec in pipelineRun details page.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: All
OS: All
high
urgent
Target Milestone: ---
: 4.5.0
Assignee: Karthik Jeeyar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1838792 1839036
TreeView+ depends on / blocked
 
Reported: 2020-05-13 12:47 UTC by Karthik Jeeyar
Modified: 2020-07-13 17:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Embedded pipeline spec is not supported in UI Consequence: When the user creates the pipelinerun via cli or using the yaml https://gist.githubusercontent.com/praveen4g0/417eb5c173831a18b85737e45f564e12/raw/9e8a717936a213c86abcbb8a9af16c13d29838e3/embeededpipelinespec.yaml, it breaks the UI Fix: Add additional checks to fix avoid the error in the UI Result: UI will not break in the embedded pipeline scenario
Clone Of:
: 1838792 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
console breaks if embedded pipelineSpec is passed (222.29 KB, image/png)
2020-05-13 12:47 UTC, Karthik Jeeyar
no flags Details
Handle embedded pipelineSpec in pipelineRun details page. (51.42 KB, image/png)
2020-05-22 11:06 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5425 0 None closed Bug 1835228: handle embedded pipeline spec in pipelinerun scenario 2020-06-30 10:00:22 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:38 UTC

Description Karthik Jeeyar 2020-05-13 12:47:58 UTC
Created attachment 1688017 [details]
console breaks if embedded pipelineSpec is passed

Description of problem:
Devconsole UI breaks when user creates `pipelinerun` with embedded pipeline spec and visits the pipeline run details page


Version-Release number of selected component (if applicable):
4.5, 4.4, 4.3

How reproducible:
Always

Steps to Reproduce:
1. create any namespace
2. oc apply -f https://gist.githubusercontent.com/praveen4g0/417eb5c173831a18b85737e45f564e12/raw/9e8a717936a213c86abcbb8a9af16c13d29838e3/embeededpipelinespec.yaml
3. open the pipelinerun details page from the pipeline runs list page.



Actual results:
Console UI breaks with an error


Expected results:
UI should not throw an error and it should handle the components gracefully if the pipeline details is not available.

Comment 4 spathak@redhat.com 2020-05-22 11:06:41 UTC
Created attachment 1691025 [details]
Handle embedded pipelineSpec in pipelineRun details page.

Comment 5 spathak@redhat.com 2020-05-22 11:08:12 UTC
Verified on build version: 4.5.0-0.ci-2020-05-21-230520
Browser version: Firefox73

Comment 7 errata-xmlrpc 2020-07-13 17:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.