Bug 1835232 - Inconsistency in loading states on object service dashboards
Summary: Inconsistency in loading states on object service dashboards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Storage Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: afrahman
QA Contact: Yosi Ben Shimon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 12:57 UTC by afrahman
Modified: 2020-07-13 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Inline loading state of data reduction card (7.77 KB, image/png)
2020-05-13 12:57 UTC, afrahman
no flags Details
Inline loading state of data consumption card (6.10 KB, image/png)
2020-05-13 13:26 UTC, afrahman
no flags Details
ocp_worker_stop screenshot (71.04 KB, image/png)
2020-06-17 10:44 UTC, Yosi Ben Shimon
no flags Details
ocp_worker_start screenshot (70.88 KB, image/png)
2020-06-17 10:45 UTC, Yosi Ben Shimon
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 3836 0 None closed Bug 1835232: Added skeleton loading state for data consumption and object data reduction card 2020-09-03 09:34:45 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:38 UTC

Description afrahman 2020-05-13 12:57:27 UTC
Created attachment 1688018 [details]
Inline loading state of data reduction card

Description of problem:
Inconsistency in loading states on object service dashboards

Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
Easily 

Steps to Reproduce:
1.Install OCS and storage clsuter
2.Go to the object service dashboard 
3. Check loading states of data consumption and data reduction card

Actual results:
Loading boxes are not used for data consumption and object service dashboard but inline loading

Expected results:
Loading boxes should be used for data consumption and object service dashboard but inline loading

Additional info:

Comment 1 afrahman 2020-05-13 13:26:47 UTC
Created attachment 1688023 [details]
Inline loading state of data consumption card

Comment 4 Yosi Ben Shimon 2020-06-17 10:44:13 UTC
Tested on:
4.5.0-0.nightly-2020-06-17-001505

Deployed OCP on AWS.

At the start, there were no alerts and both data consumption and data reduction were looking fine.
Tried to stop one of the worker node (via AWS instances) and waited for the alerts to appear (see attachment "ocp_worker_stop").
The status of "Efficiency Ratio" and "Savings" was "Not available" as well as "No datapoints found" under Data Consumption.
Finally, I started that worker and waited for the alerts to be gone (see attachment "ocp_worker_start").
The state of "Efficiency Ratio" went back to 1:1 and "Savings" went back to "No Savings".
Also, data Consumption showed the graph again.

Moving to VERIFIED

Comment 5 Yosi Ben Shimon 2020-06-17 10:44:38 UTC
Created attachment 1697794 [details]
ocp_worker_stop screenshot

Comment 6 Yosi Ben Shimon 2020-06-17 10:45:34 UTC
Created attachment 1697795 [details]
ocp_worker_start screenshot

Comment 7 errata-xmlrpc 2020-07-13 17:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.