Bug 183530 - DBD::SQLite broken on devel
DBD::SQLite broken on devel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-DBD-SQLite (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jose Pedro Oliveira
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2006-03-01 14:51 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-DBD-SQLite-1.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 11:09:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for SQLite 3.3 compatibility (973 bytes, patch)
2006-04-04 03:52 EDT, Nigel Metheringham
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2006-03-01 14:51:58 EST
I guess you knew it already, but let's note it here for others: DBD::SQLite is
broken on devel (both the old one and the new unsuccessful build):

http://buildsys.fedoraproject.org/logs/fedora-development-extras/4873-perl-DBD-SQLite-1.11-2.fc5/
https://www.redhat.com/archives/fedora-perl-devel-list/2006-March/msg00000.html
Comment 1 Jose Pedro Oliveira 2006-03-06 13:23:40 EST
Sorry for the delay.

Do you mind if I just build DBD::SQLite using the included sqlite library
(USE_LOCAL_SQLITE=1) ?

Right now I don't have much time to look into it; I don't even have a FC-5 test
system available - I'm trying to find an available machine to install it, but
will take a few days.

jpo
Comment 2 Ville Skyttä 2006-03-06 15:34:57 EST
As usual, it would be better to use the system one.  There's at least one
database corruption bug fixed in SQLite 3.2.x series since the version bundled
in DBD-SQLite, I haven't checked whether it could bite or not.
Comment 3 Jose Pedro Oliveira 2006-03-09 14:46:35 EST
As a short term solution I building perl-DBD-SQLite with the included version of
sqlite (3.2.7). Right now the FC-4 build is also using the internal sqlite version.

The specfile patch is basically:

-CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor
+CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS=vendor USE_LOCAL_SQLITE=1

/jpo
Comment 4 Nigel Metheringham 2006-04-04 03:52:53 EDT
Created attachment 127277 [details]
Fix for SQLite 3.3 compatibility
Comment 5 Nigel Metheringham 2006-04-04 03:53:56 EDT
The CPAN reference for this bug, with fix is
   http://rt.cpan.org/Public/Bug/Display.html?id=18328

I have attached the patch I am using in my rpm (taken from that bug report) to
this entry too.
Comment 6 Jose Pedro Oliveira 2006-04-05 13:13:32 EDT
Package just built for devel with the above patch and the one for bug 187873.

SRPM and build logs available here:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/7258-perl-DBD-SQLite-1.11-4.fc6/

Could someone help test it before I sync the FC-5 branch?  

Thanks in advance,
Comment 7 Jose Pedro Oliveira 2006-04-12 11:09:03 EDT
Updated the devel and FC-5 branch to DBD::SQLite 1.12.
Built using the system sqlite.

SQLite 1.12 internal sqlite version -> 3.3.5
System SQLite version -> 3.3.3

The script
----------
#!/usr/bin/perl -w
use strict;
use DBI;

my $dbh = DBI->connect("dbi:SQLite:dbname=foo", "", "");
print "# sqlite_version = $dbh->{sqlite_version}\n";
$dbh->disconnect;
----------
outputs the following

   # sqlite_version = 3.3.3

Note You need to log in before you can comment on or make changes to this bug.