Bug 1835416 - Items added to Dev Perspective Nav by User are showing all resources when all-projects selected
Summary: Items added to Dev Perspective Nav by User are showing all resources when all...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 18:06 UTC by Jeff Phillips
Modified: 2020-07-13 17:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.ci-2020-05-13-095403 Cluster ID: 339e5583-486e-4ac1-aba5-3ebdfb24fe44 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Last Closed: 2020-07-13 17:38:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5434 0 None closed Bug 1835416: Fix for all-projects view for dev perspective resources 2020-06-24 02:33:44 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:44 UTC

Description Jeff Phillips 2020-05-13 18:06:55 UTC
Description of problem:

The pinned search pages allows you to select "all projects" and shows you the resources across all the namespaces. It should be showing the project selection page so that the user has to select a project to see resources for that project.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select `all projects` from the project selector.
2. Navigate to the Developer perspective.
3. Add pins to the navigation or choose an existing pinned item

Actual results:

You see resource from across all projects

Expected results:

You should be prompted to select a project and the list of projects should be shown.
Selecting a project will then show you those resources for the project.

Additional info:

Comment 3 Gajanan More 2020-06-11 06:55:08 UTC
I have validated the bugzilla on the:
Build: 4.5.0-0.nightly-2020-06-10-224736
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:38:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.