Bug 1835425 - Fix it so we don't show Remove Trigger when there are no triggers
Summary: Fix it so we don't show Remove Trigger when there are no triggers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.0
Assignee: Vikram Raj
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-13 18:24 UTC by Vikram Raj
Modified: 2020-07-13 17:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix it so we don't show Remove Trigger when there are no triggers (13.06 KB, image/png)
2020-05-28 23:11 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5433 0 None closed Bug 1835425: Don't show Remove Trigger when there are no triggers 2020-06-24 02:34:02 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:38:44 UTC

Description Vikram Raj 2020-05-13 18:24:21 UTC
Description of problem:
When there are no triggers, the modal opens with a disabled dropdown.

We should do better, like disabling the kebab menu option... unfortunately the information is not readably available... so we'll have to fetch it which may not be cheap. Some thinking needs to be done here.


How reproducible:


Steps to Reproduce:
1. Create a pipeline.
2. in the kebab menu of the pipeline you will see the Remove Trigger options even if there is no trigger is present for the pipeline.


Actual results:
the Remove Trigger options even if there is no trigger is present for the pipeline.

Expected results:
Remove Trigger option should not be present if there is no trigger present.

Additional info:

Comment 3 spathak@redhat.com 2020-05-28 23:10:39 UTC
Validated on build version: 4.5.0-0.nightly-2020-05-28-070355
Browser version: firefox73

Comment 4 spathak@redhat.com 2020-05-28 23:11:14 UTC
Created attachment 1693192 [details]
Fix it so we don't show Remove Trigger when there are no triggers

Comment 5 errata-xmlrpc 2020-07-13 17:38:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.