Bug 1835603 - VM fails to be scheduled after adding and removing affinity rule
Summary: VM fails to be scheduled after adding and removing affinity rule
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Yaacov Zamir
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-14 07:36 UTC by Radim Hrazdil
Modified: 2020-07-13 17:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5465 0 None open Bug 1835603: Remove affinity from yaml when no affinties 2020-06-24 02:35:50 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:01 UTC

Description Radim Hrazdil 2020-05-14 07:36:36 UTC
Description of problem:

When an affinity rule is added and removed, the VM fails to be scheduled. Events read the following error:

Error creating pod: Pod "virt-launcher-vm-example3-vsfg7" is invalid: spec.affinity.nodeAffinity.requiredDuringSchedulingIgnoredDuringExecution.nodeSelectorTerms: Required value: must have at least one node selector term


The problem is in leaving the folling in the VM manifest:
    spec:
      affinity:
        nodeAffinity:
          requiredDuringSchedulingIgnoredDuringExecution:
            nodeSelectorTerms: []
        podAffinity: {}
        podAntiAffinity: {}


Afther removing the affinity-related keys, VM schedules as expected.


Version-Release number of selected component (if applicable):
OCP 4.5
CNV 2.3 (2.4 is blocked ATM)

How reproducible:
100%

Comment 3 Radim Hrazdil 2020-05-20 11:39:43 UTC
Verified in console release-4.5 branch commit: 5994c64ee529b650bae348ef78ebc23dca8db5c5

Comment 4 errata-xmlrpc 2020-07-13 17:38:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.