Bug 183563 - gnome shutdown dialog timer does not count down
gnome shutdown dialog timer does not count down
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-01 19:24 EST by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 09:00:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the shut down dialog (12.30 KB, image/png)
2006-03-01 19:25 EST, Bernard Johnson
no flags Details

  None (edit)
Description Bernard Johnson 2006-03-01 19:24:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060223 Fedora/1.5.0.1-5 Firefox/1.5.0.1

Description of problem:
I'm not sure I got the right component here.

If I click System -> Shut Down ... on the panel, the shutdown dialog pops up and says "This system will automatically shut down in 60 seconds".  The timer does not count down.  After approximately 60 seconds, the computer shuts down.

Under some conditions that I've not been able to pinpoint, the time will erratically count down (like changing 10 seconds at a time).  It seems to be somewhat related to moving around windows.

Version-Release number of selected component (if applicable):
gnome-panel-2.13.91-4

How reproducible:
Always

Steps to Reproduce:
1. click system -> shut down
2. observe
3. system shuts down without timer changing
  

Actual Results:  timer did not count down

Expected Results:  timer should count down to show time remaining

Additional info:
Comment 1 Bernard Johnson 2006-03-01 19:25:29 EST
Created attachment 125507 [details]
the shut down dialog

the shut down dialog
Comment 2 Matthias Clasen 2006-03-01 22:08:55 EST
It was changed to count 60, 50, 40, 30, 29, 28 ...
Thats what you may be seeing
Comment 3 Bernard Johnson 2006-03-02 03:51:37 EST
Hmm.  Interesting.  What problem was being solved by having it count like that?
 I find it confusing.
Comment 4 Matthias Clasen 2006-03-02 09:00:03 EST
the problem of immediate user panic upon seeing the countdown
Comment 5 Bernard Johnson 2006-03-02 17:57:11 EST
I laughed - then I realized you were serious.
Comment 6 David Timms 2006-03-13 09:18:56 EST
what wbout the problem of immediate user panic when they think the machine has
stopped responding (no updates each second) for ten seconds.

Is this a fedora community changeable thing, or driven by upstream gnome or
whatever ?
Comment 7 Ray Strode [halfline] 2006-03-13 21:01:57 EST
IIRC, someone filed a bug in the fedora tracker and Matthias got things changed
to the current behavior upstream, but I might be wrong.

It's possible what we have now isn't the right interaction.  This should
definitely be taken upstream though.
Comment 8 Shanmugasundaram Doraisamy 2006-07-13 08:21:49 EDT
(In reply to comment #7)
> IIRC, someone filed a bug in the fedora tracker and Matthias got things changed
> to the current behavior upstream, but I might be wrong.
> 
> It's possible what we have now isn't the right interaction.  This should
> definitely be taken upstream though.

Is there a way to reduce the time take to logout?  If so how?

Shan.

Note You need to log in before you can comment on or make changes to this bug.