Bug 1835632 - Show Default icon for eventSource for context-menu in topology view
Summary: Show Default icon for eventSource for context-menu in topology view
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-14 08:29 UTC by Jaivardhan Kumar
Modified: 2020-07-13 17:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:38:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
icon for event source (195.57 KB, image/png)
2020-05-19 05:00 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5437 0 None closed Bug 1835632: fixes eventsource icon in context menu 2020-06-24 02:35:56 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:01 UTC

Description Jaivardhan Kumar 2020-05-14 08:29:53 UTC
Description of problem: Default icon for eventSource should be shown for context-menu in topology view, it shows help icon.

Prerequisites (if any, like setup, operators/versions): Install Serverless 1.7

Steps to Reproduce:
1. Go to DevConsole -> Add -> Container image -> Create a knative service
2. Go to Topology -> Hover on Kn Service and drag connector and stop
3. Check Context menu

Actual results: Context menu for eventSource shows Help icon
*Expected results: *Context menu for eventSource shows default icon

Reproducibility (Always/Intermittent/Only Once): Always
Build Details: Version: 4.5.0-0.ci-2020-05-13-231257

Comment 3 Gajanan More 2020-05-19 05:00:30 UTC
Created attachment 1689743 [details]
icon for event source

Comment 4 Gajanan More 2020-05-19 05:01:45 UTC
I have validated the bugzilla on the
Build: 4.5.0-0.ci-2020-05-18-204038
Browser: Google Chrome Version 81.0.4044.129
Please have a look at the shared screenshot
Marking this as verified

Comment 5 errata-xmlrpc 2020-07-13 17:38:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.