Bug 1835641 - FFMS2 isn't loaded automatically
Summary: FFMS2 isn't loaded automatically
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vapoursynth
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simone Caronni
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-14 08:56 UTC by Ivan Molodetskikh
Modified: 2021-03-23 14:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-23 14:45:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Ivan Molodetskikh 2020-05-14 08:56:50 UTC
Description of problem:
FFMS2 isn't loaded automatically even when it's installed.

Version-Release number of selected component (if applicable):
vapoursynth-libs-48-7.fc32.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install vapoursynth packages
2. Install ffms2 and ffms2-devel
3. Create a test.vpy file with:

from vapoursynth import core
core.ffms2.Source('test.mp4').set_output()

4. vspipe --info test.vpy - 

Actual results:
Script evaluation failed:
Python exception: No attribute with the name ffms2 exists. Did you mistype a plugin namespace?

Traceback (most recent call last):
  File "src/cython/vapoursynth.pyx", line 1946, in vapoursynth.vpy_evaluateScript
  File "src/cython/vapoursynth.pyx", line 1947, in vapoursynth.vpy_evaluateScript
  File "test.vpy", line 2, in <module>
    core.ffms2.Source('test.mp4').set_output()
  File "src/cython/vapoursynth.pyx", line 1679, in vapoursynth._CoreProxy.__getattr__
  File "src/cython/vapoursynth.pyx", line 1539, in vapoursynth.Core.__getattr__
AttributeError: No attribute with the name ffms2 exists. Did you mistype a plugin namespace?

Expected results:
FFMS2 is loaded successfully.

Additional info:
One workaround is to create ~/.local/lib64/vapoursynth/ and symlink libffms2.so there, then put

UserPluginDir=/home/USERNAME/.local/lib64/vapoursynth

into ~/.config/vapoursynth/vapoursynth.conf

Comment 1 Simone Caronni 2021-03-23 14:45:16 UTC
Hello, the documentation of vapoursynth says the following about plugin locations:

http://vapoursynth.com/doc/plugins.html#linux

The problem is that the package to work out of the box would need to put the plugin in /usr/lib64/vapoursynth, otherwise you need to configure one of the two variables as described in the documentation.

Comment 2 Ivan Molodetskikh 2021-03-23 14:53:30 UTC
Is it possible for the vapoursynth or the ffms2 package to create the necessary /usr/lib64/vapoursynth symlink automatically or configure it to work out of the box?


Note You need to log in before you can comment on or make changes to this bug.