Bug 1835939 - Operands related views are disappeared due to missing Operand's `displayName` field in the CSV
Summary: Operands related views are disappeared due to missing Operand's `displayName`...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1835938
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-14 18:53 UTC by tony.wu
Modified: 2020-06-29 15:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1835938
Environment:
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
1_List-view___missing_provided-api.png (103.03 KB, image/png)
2020-05-14 18:53 UTC, tony.wu
no flags Details
2_Details-view___missing_provided-api_Name__missing_Operand_tabs_and_Operand_list-view.png (103.03 KB, image/png)
2020-05-14 18:53 UTC, tony.wu
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5565 None closed [release-4.4] Bug 1835939: Operands related views are disappeared due to missing Operand's `displayName` field in the C... 2020-06-23 14:39:40 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:11 UTC

Description tony.wu 2020-05-14 18:53:08 UTC
+++ This bug was initially created as a clone of Bug #1835938 +++

Description of problem:
Reported by Red Hat Quay Operator. 
Due to a missing `displayName` field of the "owned CRD" in the CSV file, all Operands related view (including entry links) in Console are disappeared.

Version-Release number of selected component (if applicable):
OCP 4.4/4.5

How reproducible:
100%

Steps to Reproduce:
1. Go to "OperatorHub" view, installed "Red Hat Quay" Operator to any NS.
2. Go to "Installed Operators" view <--- provided API field is missing
3. Go to "Red Hat Quay" Operator details view <--- provided API display name is missing and Operand's tab for Operand list view is missing

(*please double check if "Red Hat Quay" Operator still missing the `spec.customresourcedefinitions.owned[INDEX].displayName` in the CSV for reproducing this)

Actual results:
On "Installed Operators" view <--- provided API field is missing
On "Red Hat Quay" Operator details view <--- provided API display name is missing and Operand's tab for Operand list view is missing

Expected results:
Console could provide a safe fallback: 
IF CSV's `spec.customresourcedefinitions.owned[INDEX].displayName` is missing
THEN 
use `spec.customresourcedefinitions.owned[INDEX].kind` instead     

Since the `displayName` of the owned CRD is a non-required field in CSV's schema, but `kind` field is a required field.

Additional info:

--- Additional comment from  on 2020-05-14 18:52:32 UTC ---

Comment 1 tony.wu 2020-05-14 18:53:29 UTC
Created attachment 1688587 [details]
1_List-view___missing_provided-api.png

Comment 2 tony.wu 2020-05-14 18:53:48 UTC
Created attachment 1688588 [details]
2_Details-view___missing_provided-api_Name__missing_Operand_tabs_and_Operand_list-view.png

Comment 5 Cyril 2020-05-28 14:19:08 UTC
Have PR for this bug - https://github.com/openshift/console/pull/5565. Waiting for dependent bug to be verified.

Comment 9 shahan 2020-06-22 05:05:09 UTC
Go to "OperatorHub" view, installed "Red Hat Quay" Operator to any NS.
check the installed operator and detail page, they both show the display name
4.4.0-0.nightly-2020-06-21-210301

Comment 11 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.