Bug 1836177 - Wrong sample CR shown for OLM managed CR
Summary: Wrong sample CR shown for OLM managed CR
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-15 10:45 UTC by Jan Safranek
Modified: 2020-07-13 17:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Create link on the operator details -> resource instance list page for cluster-scope resources was incorrect. Consequence: Link lead to the incorrect resource creation page. Fix: Update the create link to point to the correct page. Result: Correct resource page and sample data is shown when creating a cluster-scoped resource from the operand details -> resource instance list page.
Clone Of:
Environment:
Last Closed: 2020-07-13 17:39:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (191.67 KB, image/png)
2020-05-25 03:08 UTC, XiaochuanWang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5495 0 None closed Bug 1836177: Fix create button for cluster-scope operand instances tab 2020-07-02 20:11:48 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:42 UTC

Description Jan Safranek 2020-05-15 10:45:01 UTC
"Create EBS CSI Driver" shows a wrong CR sample:

Steps to Reproduce:
1. Install AWS EBS CSI driver operator through OLM
(this may be hard, because it's scheduled to be released in 4.5, so the default OperatorHub does not have it yet)

CRD + CSV: https://github.com/openshift/aws-ebs-csi-driver-operator/tree/master/bundle/manifests

2. Click: "Installed Operators" -> "EBS CSI Driver" in "Provided API column" -> "Create EBS CSI Driver"

Actual results:

This template shows up:
apiVersion: csi.openshift.io/v1alpha1
kind: AWSEBSDriver
metadata:
  name: example
spec: {}

Expected results:

Template from CSV:
apiVersion: csi.openshift.io/v1alpha1
kind: AWSEBSDriver
metadata:
  name: cluster
  labels: {}
spec:
  logLevel: Normal
  managementState: Managed
  operatorLogLevel: Normal


Additional info:
I get the correct sample when I go through "Installed Operators" -> "AWS EBS CSI Operator" -> "(+) Create Instance".

I checked a random operator (Local Storage), it offers the same sample for both ways how to create the CR. The main difference is that the AWSEBSDriver CRs are not namespaced, while LocalVolumes are.

Comment 1 Jan Safranek 2020-05-18 08:10:11 UTC
Simple way how to make AWS EBS operator available in OperatorHub: https://bugzilla.redhat.com/show_bug.cgi?id=1828958#c5

Comment 4 XiaochuanWang 2020-05-25 03:08:39 UTC
Created attachment 1691675 [details]
Verification screenshot

Comment 5 XiaochuanWang 2020-05-25 03:09:53 UTC
The default YAML content of Create AWSEBSDriver view is as expected.
Please refer to the screenshot.
Verified on 4.5.0-0.nightly-2020-05-24-191212

Comment 6 errata-xmlrpc 2020-07-13 17:39:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.