Bug 183624 - ncpfs doesn't support 64-bit file size
ncpfs doesn't support 64-bit file size
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 06:46 EST by vvs
Modified: 2015-01-04 17:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-04 15:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vvs 2006-03-02 06:46:32 EST
Description of problem:

After I mounted remote NetWare filesystem all files with sizes over 4G appear as
only 4G-1.

Version-Release number of selected component (if applicable):

kernel-2.6.15-1.1831_FC4

How reproducible:

Always

Steps to Reproduce:
1. ncpmount -o tcp -A serverip -S servername -U username /mountpoint
2. cd /mountpoint
3. ls -l
  
Actual results:

All files with sizes over 4G will show as 4G-1

Expected results:

They should show as they are

Additional info:

We have NetWare 6.5 SP5 with NSS volumes. I understand that there are no NetWare
servers at RedHat for testing, but if someone is willing to get new experience
then you can download NetWare 6.5 SP5 for free from Novell:

1st CD - http://support.novell.com/cgi-bin/search/searchtid.cgi?/2973059.htm
2nd CD - http://support.novell.com/cgi-bin/search/searchtid.cgi?/2973060.htm
Comment 1 Dave Jones 2006-03-04 15:25:24 EST
See http://www.uwsg.iu.edu/hypermail/linux/kernel/0009.1/0887.html

Due to insufficent info on the format, upstream has been unable to add support
for >4GB.
Comment 2 vvs 2006-03-06 03:58:53 EST
That post is quite dated. I'll try to contact him by mail to get more current
status. The information about 64-bit file NCPs is already published in "NetWare
Core Protocols" February 28, 2005, Page 328.
Comment 3 vvs 2006-03-07 01:59:50 EST
According to mail I received he has no plans to implement 64-bit file access.

Note You need to log in before you can comment on or make changes to this bug.