Bug 1836284 - cri-o and dependencies are missing from 4.6 mirror repo
Summary: cri-o and dependencies are missing from 4.6 mirror repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Lokesh Mandvekar
QA Contact: MinLi
URL:
Whiteboard:
Depends On:
Blocks: 1779811
TreeView+ depends on / blocked
 
Reported: 2020-05-15 14:41 UTC by Russell Teague
Modified: 2020-10-27 16:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:00:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:00:07 UTC

Description Russell Teague 2020-05-15 14:41:10 UTC
Description of problem:
cri-o, cri-tools, and related dependencies are missing from 
https://mirror.openshift.com/enterprise/all/4.6/latest/x86_64/os/Packages/

CI Failure:
https://storage.googleapis.com/origin-ci-test/logs/release-openshift-ocp-e2e-aws-scaleup-rhel7-4.6/21/build-log.txt

No package matching 'cri-tools' found available


When master opens for 4.6 development this will be blocking openshift-ansible merges.

Version-Release number of selected component (if applicable):


How reproducible:
CI: https://deck-ci.apps.ci.l2s4.p1.openshiftapps.com/job-history/origin-ci-test/logs/release-openshift-ocp-e2e-aws-scaleup-rhel7-4.6

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Lokesh Mandvekar 2020-05-22 11:25:47 UTC
cri-tools 1.18.0 now available on 4.6 brew tag as well.

Comment 7 MinLi 2020-06-11 08:08:06 UTC
verified with version : 4.6.0-0.nightly-2020-06-10-221445

sh-4.4# rpm -qa | grep cri-o
cri-o-1.19.0-4.dev.rhaos4.6.git8b8a3a0.el8.x86_64

sh-4.4# rpm -qa | grep cri-tools
cri-tools-1.18.0-3.el8.x86_64

Comment 9 errata-xmlrpc 2020-10-27 16:00:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.