Bug 1836304 - Process packagekitd crashed in pk_dbus_get_uid()
Summary: Process packagekitd crashed in pk_dbus_get_uid()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1883035 1894801 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-15 15:17 UTC by Matti Linnanvuori
Modified: 2021-01-03 13:32 UTC (History)
60 users (show)

Fixed In Version: PackageKit-1.2.2-2.fc34 PackageKit-1.2.2-2.eln105 PackageKit-1.2.2-2.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-23 01:06:52 UTC
Type: Bug


Attachments (Terms of Use)
File: backtrace (43.15 KB, text/plain)
2020-11-13 09:53 UTC, Thomas Lake
no flags Details

Description Matti Linnanvuori 2020-05-15 15:17:23 UTC
Description of problem:
[  407.085528] packagekitd[6801]: segfault at 8 ip 000055f2eadbfe4a sp 00007fff50fe01b0 error 4 in packagekitd[55f2eadba000+2a000]

touko 15 18:00:30 linnanvuori abrt-notification[8305]: Process 1472 (packagekitd) crashed in pk_dbus_get_uid()
-- Subject: ABRT has detected unexpected termination: packagekitd
-- Defined-By: ABRT
-- Support: https://bugzilla.redhat.com/
-- Documentation: man:abrt(1)
-- PROBLEM_REPORT
-- Use the abrt command-line tool for further analysis or to report
-- the problem to the appropriate support site.


Version-Release number of selected component (if applicable):
PackageKit-1.2.0-3.fc33

How reproducible:
Always

Steps to Reproduce:
1. Install the latest Rawhide
2. Boot


Actual results:
packagekitd terminates unexpectedly.

Expected results:
packagekitd does not terminate unexpectedly.

Additional info:
HP EliteBook 8730w

Comment 1 Ben Cotton 2020-08-11 15:21:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 33 development cycle.
Changing version to 33.

Comment 2 Asad Mehmood 2020-09-27 17:36:21 UTC
*** Bug 1883035 has been marked as a duplicate of this bug. ***

Comment 3 cooperbang 2020-10-30 06:51:45 UTC
Still happens during boot with Fedora 33 Final.

Comment 4 Chris Waldon 2020-10-30 12:43:05 UTC
This is happening to me during boot of Fedora 33. I tried to report it, but the reporter crashed after telling me that it was a duplicate.

Comment 5 Chris Murphy 2020-11-02 06:24:46 UTC
abrt crashing while reporting this bug is bug 1893595.

$ sudo coredumpctl gdb 944
           PID: 944 (packagekitd)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Sun 2020-11-01 12:45:37 MST (10h ago)
  Command Line: /usr/libexec/packagekitd
    Executable: /usr/libexec/packagekitd
 Control Group: /system.slice/packagekit.service
          Unit: packagekit.service
         Slice: system.slice
       Boot ID: 2b09f6d60ea54b2fb5bccc57bc374ed6
    Machine ID: ce3f1eade82d42bd891a8c15714b13cf
      Hostname: flap.local
       Storage: /var/lib/systemd/coredump/core.packagekitd.0.2b09f6d60ea54b2fb5bccc57bc374ed6.944.1604259937000000.zst
       Message: Process 944 (packagekitd) of user 0 dumped core.
                
                Stack trace of thread 944:
                #0  0x0000560ed2b4d3ea pk_dbus_get_uid (packagekitd + 0x103ea)
                #1  0x0000560ed2b69a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)
                #2  0x00007f73a98aed0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)
                #3  0x00007f73a9a210f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)
                #4  0x00007f73a9a21fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)
                #5  0x00007f73a9a72d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)
                #6  0x00007f73a9a216ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)
                #7  0x0000560ed2b4c832 main (packagekitd + 0xf832)
                #8  0x00007f73a93db1a2 __libc_start_main (libc.so.6 + 0x281a2)
                #9  0x0000560ed2b4ca7e _start (packagekitd + 0xfa7e)
                
                Stack trace of thread 950:
                #0  0x00007f73a94a9a0f __poll (libc.so.6 + 0xf6a0f)
                #1  0x00007f73a9a72d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)
                #2  0x00007f73a9a1f41f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)
                #3  0x00007f73a9a21031 glib_worker_main (libglib-2.0.so.0 + 0x51031)
                #4  0x00007f73a9a4eede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)
                #5  0x00007f73a93213f9 start_thread (libpthread.so.0 + 0x93f9)
                #6  0x00007f73a94b4b03 __clone (libc.so.6 + 0x101b03)
                
                Stack trace of thread 951:
                #0  0x00007f73a94a9a0f __poll (libc.so.6 + 0xf6a0f)
                #1  0x00007f73a9a72d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)
                #2  0x00007f73a9a216ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)
                #3  0x00007f73a98ba6b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)
                #4  0x00007f73a9a4eede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)
                #5  0x00007f73a93213f9 start_thread (libpthread.so.0 + 0x93f9)
                #6  0x00007f73a94b4b03 __clone (libc.so.6 + 0x101b03)
                
                Stack trace of thread 952:
                #0  0x00007f73a94af50d syscall (libc.so.6 + 0xfc50d)
                #1  0x00007f73a9a6da38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)
                #2  0x00007f73a99f3341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)
                #3  0x00007f73a99f34c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)
                #4  0x00007f73a9a51ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)
                #5  0x00007f73a9a4eede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)
                #6  0x00007f73a93213f9 start_thread (libpthread.so.0 + 0x93f9)
                #7  0x00007f73a94b4b03 __clone (libc.so.6 + 0x101b03)

GNU gdb (GDB) Fedora 9.2-7.fc33
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/libexec/packagekitd...
Reading symbols from .gnu_debugdata for /usr/libexec/packagekitd...
(No debugging symbols found in .gnu_debugdata for /usr/libexec/packagekitd)
[New LWP 944]
[New LWP 950]
[New LWP 951]
[New LWP 952]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/usr/libexec/packagekitd'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000560ed2b4d3ea in pk_dbus_get_uid ()
[Current thread is 1 (Thread 0x7f73a8dfa080 (LWP 944))]
(gdb) thread apply all bt full

Thread 4 (Thread 0x7f7399f5c640 (LWP 952)):
#0  0x00007f73a94af50d in syscall () at /lib64/libc.so.6
#1  0x00007f73a9a6da38 in g_cond_wait_until () at /lib64/libglib-2.0.so.0
#2  0x00007f73a99f3341 in g_async_queue_pop_intern_unlocked () at /lib64/libglib-2.0.so.0
#3  0x00007f73a99f34c2 in g_async_queue_timeout_pop () at /lib64/libglib-2.0.so.0
#4  0x00007f73a9a51ab9 in g_thread_pool_thread_proxy.lto_priv () at /lib64/libglib-2.0.so.0
#5  0x00007f73a9a4eede in g_thread_proxy () at /lib64/libglib-2.0.so.0
#6  0x00007f73a93213f9 in start_thread () at /lib64/libpthread.so.0
#7  0x00007f73a94b4b03 in clone () at /lib64/libc.so.6

Thread 3 (Thread 0x7f739b0c7640 (LWP 951)):
#0  0x00007f73a94a9a0f in poll () at /lib64/libc.so.6
#1  0x00007f73a9a72d1e in g_main_context_iterate.constprop () at /lib64/libglib-2.0.so.0
#2  0x00007f73a9a216ab in g_main_loop_run () at /lib64/libglib-2.0.so.0
#3  0x00007f73a98ba6b6 in gdbus_shared_thread_func.lto_priv () at /lib64/libgio-2.0.so.0
#4  0x00007f73a9a4eede in g_thread_proxy () at /lib64/libglib-2.0.so.0
#5  0x00007f73a93213f9 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f73a94b4b03 in clone () at /lib64/libc.so.6

Thread 2 (Thread 0x7f739b8c8640 (LWP 950)):
#0  0x00007f73a94a9a0f in poll () at /lib64/libc.so.6
#1  0x00007f73a9a72d1e in g_main_context_iterate.constprop () at /lib64/libglib-2.0.so.0
#2  0x00007f73a9a1f41f in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00007f73a9a21031 in glib_worker_main () at /lib64/libglib-2.0.so.0
#4  0x00007f73a9a4eede in g_thread_proxy () at /lib64/libglib-2.0.so.0
#5  0x00007f73a93213f9 in start_thread () at /lib64/libpthread.so.0
#6  0x00007f73a94b4b03 in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7f73a8dfa080 (LWP 944)):
#0  0x0000560ed2b4d3ea in pk_dbus_get_uid ()
#1  0x0000560ed2b69a4b in pk_engine_daemon_method_call ()
#2  0x00007f73a98aed0e in call_in_idle_cb.lto_priv () at /lib64/libgio-2.0.so.0
#3  0x00007f73a9a210f7 in g_idle_dispatch () at /lib64/libglib-2.0.so.0
#4  0x00007f73a9a21fd7 in g_main_context_dispatch () at /lib64/libglib-2.0.so.0
--Type <RET> for more, q to quit, c to continue without paging--c
#5  0x00007f73a9a72d88 in g_main_context_iterate.constprop () at /lib64/libglib-2.0.so.0
#6  0x00007f73a9a216ab in g_main_loop_run () at /lib64/libglib-2.0.so.0
#7  0x0000560ed2b4c832 in main ()
(gdb) quit
$

Comment 6 Chris Murphy 2020-11-02 06:25:43 UTC
Crash happened with PackageKit-1.2.1-1.fc33.x86_64

Comment 7 AsciiWolf 2020-11-03 19:12:27 UTC
Same issue on Fedora 33 with PackageKit-1.2.1-1.fc33.x86_64.

Also, this was in journal log:
packagekitd[1666]: g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed

Comment 8 AsciiWolf 2020-11-03 19:14:24 UTC
It happens every time after I log in.

I have tried to report this issue with GNOME ABRT GUI, but it did not get reported.

Comment 9 Christian Kujau 2020-11-03 21:03:46 UTC
$ sudo coredumpctl gdb 4072
[sudo] password for root: 
           PID: 4072 (packagekitd)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 11 (SEGV)
     Timestamp: Tue 2020-11-03 21:47:59 CET (13min ago)
  Command Line: /usr/libexec/packagekitd
    Executable: /usr/libexec/packagekitd
 Control Group: /system.slice/packagekit.service
          Unit: packagekit.service
         Slice: system.slice
       Boot ID: f04cc6463d234915ac7c19d813f867b6
    Machine ID: a6750507e4de4a92989d887d8f379640
      Hostname: horus
       Storage: /var/lib/systemd/coredump/core.packagekitd.0.f04cc6463d234915ac7c19d813f867b6.4072.1604436479000000.zst
       Message: Process 4072 (packagekitd) of user 0 dumped core.
                
                Stack trace of thread 4072:
                #0  0x00005617c417b3ea pk_dbus_get_uid (packagekitd + 0x103ea)
                #1  0x00005617c4197a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)
                #2  0x00007fe10623cd0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)
                #3  0x00007fe1063af0f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)
                #4  0x00007fe1063affd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)
                #5  0x00007fe106400d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)
                #6  0x00007fe1063af6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)
                #7  0x00005617c417a832 main (packagekitd + 0xf832)
                #8  0x00007fe105d691a2 __libc_start_main (libc.so.6 + 0x281a2)
                #9  0x00005617c417aa7e _start (packagekitd + 0xfa7e)
                
                Stack trace of thread 4076:
                #0  0x00007fe105e37a0f __poll (libc.so.6 + 0xf6a0f)
                #1  0x00007fe106400d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)
                #2  0x00007fe1063af6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)
                #3  0x00007fe1062486b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)
                #4  0x00007fe1063dcede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)
                #5  0x00007fe105caf3f9 start_thread (libpthread.so.0 + 0x93f9)
                #6  0x00007fe105e42b03 __clone (libc.so.6 + 0x101b03)
                
                Stack trace of thread 4075:
                #0  0x00007fe105e37a0f __poll (libc.so.6 + 0xf6a0f)
                #1  0x00007fe106400d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)
                #2  0x00007fe1063ad41f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)
                #3  0x00007fe1063af031 glib_worker_main (libglib-2.0.so.0 + 0x51031)
                #4  0x00007fe1063dcede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)
                #5  0x00007fe105caf3f9 start_thread (libpthread.so.0 + 0x93f9)
                #6  0x00007fe105e42b03 __clone (libc.so.6 + 0x101b03)

Comment 10 Daniel Rusek 2020-11-04 12:52:18 UTC
I also have the same issue on a clean, fully updated Fedora 33 Workstation vm installation.

Comment 11 Chris Murphy 2020-11-05 06:03:58 UTC
*** Bug 1894801 has been marked as a duplicate of this bug. ***

Comment 12 Takehiko Abe 2020-11-05 07:53:47 UTC
PackageKit-1.2.2-1.fc33.x86_64 in update-testing crashes.

Comment 13 Daniel Rusek 2020-11-05 12:07:01 UTC
This upstream PR should fixed the crash: https://github.com/hughsie/PackageKit/pull/437

However, it was not included in the latest build for some reason.

Comment 14 Vít Ondruch 2020-11-09 14:32:50 UTC
(In reply to Daniel Rusek from comment #13)
> This upstream PR should fixed the crash:
> https://github.com/hughsie/PackageKit/pull/437

PR and scratch build with the pat, if that helps:

https://src.fedoraproject.org/rpms/PackageKit/pull-request/6
https://koji.fedoraproject.org/koji/taskinfo?taskID=55239989

(I have yet to test it).

Comment 15 Daniel Rusek 2020-11-09 15:00:09 UTC
Any chance you could do a F33 build? I don't have any Rawhide machine here at the moment and the F34 build has broken dependencies on my F33 machine.

Comment 16 Artem 2020-11-09 15:10:20 UTC
(In reply to Daniel Rusek from comment #15)
> Any chance you could do a F33 build? I don't have any Rawhide machine here
> at the moment and the F34 build has broken dependencies on my F33 machine.

COPR build for testing https://copr.fedorainfracloud.org/coprs/atim/PackageKit/

Comment 17 Daniel Rusek 2020-11-09 15:37:01 UTC
Thanks! I can confirm that after installing the COPR build, PackageKit no longer crashes on my machine.

Comment 18 Rex Dieter 2020-11-09 16:38:54 UTC
PR merged,
https://src.fedoraproject.org/rpms/PackageKit/pull-request/6

builds underway

Comment 19 Fedora Update System 2020-11-09 16:45:53 UTC
FEDORA-2020-6010d99876 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2020-11-09 17:03:51 UTC
FEDORA-2020-a20e3343ab has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2020-11-09 18:18:50 UTC
FEDORA-2020-7699a31d2a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7699a31d2a

Comment 22 Fedora Update System 2020-11-10 02:20:07 UTC
FEDORA-2020-7699a31d2a has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7699a31d2a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7699a31d2a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Adam Williamson 2020-11-10 20:28:15 UTC
The fix for this looks to have broken update notifications, according to the openQA test at least. File as https://bugzilla.redhat.com/show_bug.cgi?id=1896540

Comment 24 Fedora Update System 2020-11-10 20:29:17 UTC
FEDORA-2020-7699a31d2a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7699a31d2a

Comment 25 Fedora Update System 2020-11-11 02:19:47 UTC
FEDORA-2020-7699a31d2a has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7699a31d2a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7699a31d2a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 26 Daniel Rusek 2020-11-11 16:06:07 UTC
I am reopening this issue since the fix apparently caused another regression (see bz#1896540) and was unpushed from stable on F33.

Comment 27 Daniel Rusek 2020-11-12 14:18:07 UTC
I really hope that this issue will get fixed properly since it apparently causes PackageKit to crash during every boot on all Fedora 33 Workstation installations.

Comment 28 Adam Williamson 2020-11-12 17:29:48 UTC
It certainly doesn't do that, because it never made it out of updates-testing.

Comment 29 Daniel Rusek 2020-11-12 18:20:56 UTC
Sorry, but that is not correct. I have tested this on multiple Fedora 33 Workstation systems (that certainly do not have) updates-testing enabled and have segfault in dmesg + ABRT report on *every* of them.

They all have PackageKit-1.2.1-1.fc33.x86_64 that was pushed to stable two months ago: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9813075759

$ rpm -q PackageKit
PackageKit-1.2.1-1.fc33.x86_64

$ dmesg | grep packagekit
[ 2347.522726] packagekitd[47614]: segfault at 8 ip 000055eb8b62c3ea sp 00007ffca4e8ca20 error 4 in packagekitd[55eb8b628000+28000]

$ sudo abrt
e37f8f9 12x PackageKit 2020-11-04 13:09:03

They all have PackageKit-1.2.1-1.fc33.x86_64 which was pushed to stable two months ago: https://bodhi.fedoraproject.org/updates/FEDORA-2020-9813075759

Comment 30 Daniel Rusek 2020-11-12 18:23:05 UTC
Sorry for the typos in previous comment. Also, I forgot to mention that some of the F33 systems were newly installed and fully updated VMs.

Comment 31 Adam Williamson 2020-11-12 18:28:58 UTC
Oh, sorry, I was thinking about the follow-up bug, not the initial problem.

Comment 32 talibpierson 2020-11-12 20:42:46 UTC
PackageKit crashed on boot or login.

reason: packagekitd killed by SIGSEGV
crash_function: pk_dbus_get_uid
cmdline/executable: /usr/libexec/packagekitd

$ rpm -q PackageKit
PackageKit-1.2.1-1.fc33.x86_64
$ dmesg | grep packagekit
[   79.092296] packagekitd[1420]: segfault at 8 ip 000055e28b7e63ea sp 00007ffc111efa10 error 4 in packagekitd[55e28b7e2000+28000]
$ sudo abrt
0c1c92f 1x PackageKit 2020-11-12 12:10:12

User Logs:
--Nov 12 12:09:20 xps-13-9370 PackageKit[1420]: daemon start
Nov 12 12:10:11 xps-13-9370 packagekitd[1420]: g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
Nov 12 12:10:11 xps-13-9370 PackageKit[2663]: daemon start
--

Comment 33 Thomas Lake 2020-11-13 09:53:30 UTC
Similar problem has been detected:

Unknown - crashes in background on boot.
Journal message:  packagekitd[2223]: g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed

dmesg:
[  544.631934] packagekitd[11834]: segfault at 8 ip 00005579997b13ea sp 00007ffc1739af60 error 4 in packagekitd[5579997ad000+28000]
[  544.631940] Code: ff ff 41 bc f4 01 00 00 eb 80 66 0f 1f 44 00 00 48 8b 45 d0 4c 89 e1 48 8d 15 6e 3d 02 00 be 10 00 00 00 48 8d 3d 2f 3d 02 00 <4c> 8b 40 08 31 c0 e8 6b d3 ff ff eb a3 66 0f 1f 84 00 00 00 00 00

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=57948543b2a04f72a239fe90cd4b8acd;i=a020;b=924c2d0559e5404b81a2980a5f4775b5;m=1230b96b5;t=5b3e4b1234c18;x=160452ddeb909c2e
kernel:         5.8.18-300.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 34 Thomas Lake 2020-11-13 09:53:34 UTC
Created attachment 1729045 [details]
File: backtrace

Comment 35 Ladar Levison 2020-11-13 19:32:59 UTC
Similar problem has been detected:

I connected to the guest virtual machine using "remote-viewer spice://127.0.0.1:5901" from a CentOS 8 host 
machine. I enabled the second display, up popped the window. I clicked full screen on virtual display 2, and 
it went full screen. The virtual display resized accordingly. Then I hit full screen on virtual display 1, and that's 
when the spice connection crashed. I was able to log into the guest via SSH, but couldn't get access to the console 
without rebooting. The only clue I found was in the log, and of course the packagekit crashes associated with this
bug report. I repeated the process several times. 

In case it isn't obvious, I have the guest setup with a QXL graphics device, with 2 heads. 



Nov 13 07:14:19 proxyfed systemd-coredump[2931]: Process 1862 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1862:#012#0  0x0000556f694fc3ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x0000556f69518a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f1188183d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f11882f60f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f11882f6fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f1188347d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f11882f66ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x0000556f694fb832 main (packagekitd + 0xf832)#012#8  0x00007f1187cb01a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x0000556f694fba7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 1866:#012#0  0x00007f1187d7ea0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f1188347d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f11882f441f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f11882f6031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f1188323ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f1187bf63f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f1187d89b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1867:#012#0  0x00007f1187d7ea0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f1188347d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f11882f66ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f118818f6b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f1188323ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f1187bf63f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f1187d89b03 __clone (libc.so.6 + 0x101b03)
Nov 13 07:14:19 proxyfed systemd[1]: systemd-coredump@0-2930-0.service: Succeeded.
Nov 13 07:43:41 proxyfed systemd-coredump[2488]: Process 2021 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 2021:#012#0  0x00005607b870a3ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x00005607b8726a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007fde25e17d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007fde25f8a0f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007fde25f8afd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007fde25fdbd88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007fde25f8a6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x00005607b8709832 main (packagekitd + 0xf832)#012#8  0x00007fde259441a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x00005607b8709a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 2023:#012#0  0x00007fde25a12a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fde25fdbd1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fde25f8a6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007fde25e236b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007fde25fb7ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fde2588a3f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fde25a1db03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 2022:#012#0  0x00007fde25a12a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fde25fdbd1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fde25f8841f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007fde25f8a031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007fde25fb7ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fde2588a3f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fde25a1db03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 2026:#012#0  0x00007fde25a1850d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007fde25fd6a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007fde25f5c341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007fde25f5c4c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007fde25fbaab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007fde25fb7ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007fde2588a3f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007fde25a1db03 __clone (libc.so.6 + 0x101b03)
Nov 13 07:43:41 proxyfed systemd[1]: systemd-coredump@0-2485-0.service: Succeeded.
Nov 13 08:08:19 proxyfed systemd-coredump[2506]: Process 1999 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1999:#012#0  0x00005648ce2093ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x00005648ce225a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f2e92258d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f2e923cb0f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f2e923cbfd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f2e9241cd88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f2e923cb6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x00005648ce208832 main (packagekitd + 0xf832)#012#8  0x00007f2e91d851a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x00005648ce208a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 2002:#012#0  0x00007f2e91e53a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f2e9241cd1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f2e923c941f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f2e923cb031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f2e923f8ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f2e91ccb3f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f2e91e5eb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 2003:#012#0  0x00007f2e91e53a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f2e9241cd1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f2e923cb6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f2e922646b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f2e923f8ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f2e91ccb3f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f2e91e5eb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 2004:#012#0  0x00007f2e91e5950d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007f2e92417a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007f2e9239d341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007f2e9239d4c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007f2e923fbab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007f2e923f8ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007f2e91ccb3f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007f2e91e5eb03 __clone (libc.so.6 + 0x101b03)
Nov 13 08:08:19 proxyfed systemd[1]: systemd-coredump@0-2505-0.service: Succeeded.
Nov 13 08:17:30 proxyfed systemd-coredump[2430]: Process 1944 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1944:#012#0  0x000055c4b456b3ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x000055c4b4587a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007fedb5c90d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007fedb5e030f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007fedb5e03fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007fedb5e54d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007fedb5e036ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x000055c4b456a832 main (packagekitd + 0xf832)#012#8  0x00007fedb57bd1a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x000055c4b456aa7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 1947:#012#0  0x00007fedb588ba0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fedb5e54d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fedb5e036ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007fedb5c9c6b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007fedb5e30ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fedb57033f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fedb5896b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1946:#012#0  0x00007fedb588ba0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fedb5e54d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fedb5e0141f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007fedb5e03031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007fedb5e30ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fedb57033f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fedb5896b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1948:#012#0  0x00007fedb589150d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007fedb5e4fa38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007fedb5dd5341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007fedb5dd54c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007fedb5e33ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007fedb5e30ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007fedb57033f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007fedb5896b03 __clone (libc.so.6 + 0x101b03)
Nov 13 08:17:30 proxyfed systemd[1]: systemd-coredump@0-2425-0.service: Succeeded.
Nov 13 08:18:39 proxyfed systemd-coredump[2451]: Process 1990 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1990:#012#0  0x0000556883ed23ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x0000556883eeea4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f3c979f9d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f3c97b6c0f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f3c97b6cfd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f3c97bbdd88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f3c97b6c6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x0000556883ed1832 main (packagekitd + 0xf832)#012#8  0x00007f3c975261a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x0000556883ed1a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 1994:#012#0  0x00007f3c975f4a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f3c97bbdd1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f3c97b6a41f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f3c97b6c031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f3c97b99ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f3c9746c3f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f3c975ffb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1995:#012#0  0x00007f3c975f4a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f3c97bbdd1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f3c97b6c6ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f3c97a056b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f3c97b99ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f3c9746c3f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f3c975ffb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1997:#012#0  0x00007f3c975fa50d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007f3c97bb8a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007f3c97b3e341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007f3c97b3e4c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007f3c97b9cab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007f3c97b99ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007f3c9746c3f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007f3c975ffb03 __clone (libc.so.6 + 0x101b03)
Nov 13 08:18:39 proxyfed systemd[1]: systemd-coredump@0-2447-0.service: Succeeded.
Nov 13 08:23:59 proxyfed systemd-coredump[2497]: Process 2016 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 2016:#012#0  0x00005647fce2b3ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x00005647fce47a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f8161bbfd0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f8161d320f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f8161d32fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f8161d83d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f8161d326ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x00005647fce2a832 main (packagekitd + 0xf832)#012#8  0x00007f81616ec1a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x00005647fce2aa7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 2019:#012#0  0x00007f81617baa0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f8161d83d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f8161d326ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f8161bcb6b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f8161d5fede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f81616323f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f81617c5b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 2018:#012#0  0x00007f81617baa0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f8161d83d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f8161d3041f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f8161d32031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f8161d5fede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f81616323f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f81617c5b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 2022:#012#0  0x00007f81617c050d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007f8161d7ea38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007f8161d04341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007f8161d044c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007f8161d62ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007f8161d5fede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007f81616323f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007f81617c5b03 __clone (libc.so.6 + 0x101b03)
Nov 13 08:23:59 proxyfed systemd[1]: systemd-coredump@0-2493-0.service: Succeeded.
Nov 13 09:57:14 proxyfed systemd-coredump[2412]: Process 1935 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1935:#012#0  0x0000560872cf43ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x0000560872d10a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f1986196d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f19863090f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f1986309fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f198635ad88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f19863096ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x0000560872cf3832 main (packagekitd + 0xf832)#012#8  0x00007f1985cc31a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x0000560872cf3a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 1944:#012#0  0x00007f1985d91a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f198635ad1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f198630741f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f1986309031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f1986336ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f1985c093f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f1985d9cb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1945:#012#0  0x00007f1985d91a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f198635ad1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f19863096ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f19861a26b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f1986336ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f1985c093f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f1985d9cb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1946:#012#0  0x00007f1985d9750d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007f1986355a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007f19862db341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007f19862db4c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007f1986339ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007f1986336ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007f1985c093f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007f1985d9cb03 __clone (libc.so.6 + 0x101b03)
Nov 13 09:57:14 proxyfed systemd[1]: systemd-coredump@0-2406-0.service: Succeeded.
Nov 13 12:52:42 proxyfed systemd-coredump[2443]: Process 1971 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1971:#012#0  0x00005635ad86e3ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x00005635ad88aa4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007fbeff2c5d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007fbeff4380f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007fbeff438fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007fbeff489d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007fbeff4386ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x00005635ad86d832 main (packagekitd + 0xf832)#012#8  0x00007fbefedf21a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x00005635ad86da7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 1976:#012#0  0x00007fbefeec650d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007fbeff484a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007fbeff40a341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007fbeff40a4c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007fbeff468ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007fbeff465ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007fbefed383f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007fbefeecbb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1974:#012#0  0x00007fbefeec0a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fbeff489d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fbeff43641f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007fbeff438031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007fbeff465ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fbefed383f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fbefeecbb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1975:#012#0  0x00007fbefeec0a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fbeff489d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fbeff4386ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007fbeff2d16b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007fbeff465ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fbefed383f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fbefeecbb03 __clone (libc.so.6 + 0x101b03)
Nov 13 12:52:42 proxyfed systemd[1]: systemd-coredump@0-2438-0.service: Succeeded.
Nov 13 13:02:04 proxyfed systemd-coredump[2462]: Process 1970 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 1970:#012#0  0x000055e96a9233ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x000055e96a93fa4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007fae61560d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007fae616d30f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007fae616d3fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007fae61724d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007fae616d36ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x000055e96a922832 main (packagekitd + 0xf832)#012#8  0x00007fae6108d1a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x000055e96a922a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 1975:#012#0  0x00007fae6116150d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007fae6171fa38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007fae616a5341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007fae616a54c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007fae61703ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007fae61700ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007fae60fd33f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007fae61166b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1973:#012#0  0x00007fae6115ba0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fae61724d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fae616d141f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007fae616d3031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007fae61700ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fae60fd33f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fae61166b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 1974:#012#0  0x00007fae6115ba0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007fae61724d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007fae616d36ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007fae6156c6b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007fae61700ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007fae60fd33f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007fae61166b03 __clone (libc.so.6 + 0x101b03)
Nov 13 13:02:04 proxyfed systemd[1]: systemd-coredump@0-2461-0.service: Succeeded.
Nov 13 13:13:40 proxyfed systemd-coredump[5118]: Process 3118 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 3118:#012#0  0x000055f986fba3ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x000055f986fd6a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f4998403d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f49985760f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f4998576fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f49985c7d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f49985766ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x000055f986fb9832 main (packagekitd + 0xf832)#012#8  0x00007f4997f301a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x000055f986fb9a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 3122:#012#0  0x00007f4997ffea0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f49985c7d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f49985766ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f499840f6b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f49985a3ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f4997e763f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f4998009b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 3124:#012#0  0x00007f499800450d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007f49985c2a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007f4998548341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007f49985484c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007f49985a6ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007f49985a3ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007f4997e763f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007f4998009b03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 3121:#012#0  0x00007f4997ffea0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f49985c7d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f499857441f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f4998576031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f49985a3ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f4997e763f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f4998009b03 __clone (libc.so.6 + 0x101b03)
Nov 13 13:13:40 proxyfed systemd[1]: systemd-coredump@0-5116-0.service: Succeeded.
Nov 13 13:17:22 proxyfed systemd-coredump[5241]: Process 3351 (packagekitd) of user 0 dumped core.#012#012Stack trace of thread 3351:#012#0  0x00005587c63563ea pk_dbus_get_uid (packagekitd + 0x103ea)#012#1  0x00005587c6372a4b pk_engine_daemon_method_call (packagekitd + 0x2ca4b)#012#2  0x00007f8e4bf85d0e call_in_idle_cb.lto_priv.2 (libgio-2.0.so.0 + 0xfcd0e)#012#3  0x00007f8e4c0f80f7 g_idle_dispatch (libglib-2.0.so.0 + 0x510f7)#012#4  0x00007f8e4c0f8fd7 g_main_context_dispatch (libglib-2.0.so.0 + 0x51fd7)#012#5  0x00007f8e4c149d88 g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d88)#012#6  0x00007f8e4c0f86ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#7  0x00005587c6355832 main (packagekitd + 0xf832)#012#8  0x00007f8e4bab21a2 __libc_start_main (libc.so.6 + 0x281a2)#012#9  0x00005587c6355a7e _start (packagekitd + 0xfa7e)#012#012Stack trace of thread 3354:#012#0  0x00007f8e4bb80a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f8e4c149d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f8e4c0f641f g_main_context_iteration (libglib-2.0.so.0 + 0x4f41f)#012#3  0x00007f8e4c0f8031 glib_worker_main (libglib-2.0.so.0 + 0x51031)#012#4  0x00007f8e4c125ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f8e4b9f83f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f8e4bb8bb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 3360:#012#0  0x00007f8e4bb8650d syscall (libc.so.6 + 0xfc50d)#012#1  0x00007f8e4c144a38 g_cond_wait_until (libglib-2.0.so.0 + 0x9da38)#012#2  0x00007f8e4c0ca341 g_async_queue_pop_intern_unlocked (libglib-2.0.so.0 + 0x23341)#012#3  0x00007f8e4c0ca4c2 g_async_queue_timeout_pop (libglib-2.0.so.0 + 0x234c2)#012#4  0x00007f8e4c128ab9 g_thread_pool_thread_proxy.lto_priv.0 (libglib-2.0.so.0 + 0x81ab9)#012#5  0x00007f8e4c125ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#6  0x00007f8e4b9f83f9 start_thread (libpthread.so.0 + 0x93f9)#012#7  0x00007f8e4bb8bb03 __clone (libc.so.6 + 0x101b03)#012#012Stack trace of thread 3356:#012#0  0x00007f8e4bb80a0f __poll (libc.so.6 + 0xf6a0f)#012#1  0x00007f8e4c149d1e g_main_context_iterate.constprop.0 (libglib-2.0.so.0 + 0xa2d1e)#012#2  0x00007f8e4c0f86ab g_main_loop_run (libglib-2.0.so.0 + 0x516ab)#012#3  0x00007f8e4bf916b6 gdbus_shared_thread_func.lto_priv.0 (libgio-2.0.so.0 + 0x1086b6)#012#4  0x00007f8e4c125ede g_thread_proxy (libglib-2.0.so.0 + 0x7eede)#012#5  0x00007f8e4b9f83f9 start_thread (libpthread.so.0 + 0x93f9)#012#6  0x00007f8e4bb8bb03 __clone (libc.so.6 + 0x101b03)
Nov 13 13:17:22 proxyfed systemd[1]: systemd-coredump@0-5240-0.service: Succeeded.


reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=6de16e3d7e914c379a3c082cbb715dd6;i=ec68;b=b5fe97b9bc4f4cf880a7d234692bd783;m=de7363;t=5b401d385de84;x=b22042435b7164d9
kernel:         5.8.18-300.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       unknown
type:           CCpp
uid:            0

Comment 36 Ladar Levison 2020-11-13 20:27:15 UTC
Similar problem has been detected:

Running 2 displays works. But when I maximize both windows (not full screen, just maximize) it crashes. I'm trying to use two monitors with a 1920x1200 native resolution.

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=c197c410cfbe4c67b4b09e73bfc727c0;i=4248;b=3f92db89d24e49d48e38ed11e40ea75f;m=3d0b546;t=5b402c93359df;x=a476fc9bd1e948d3
kernel:         5.8.18-300.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 37 Clinton Work 2020-11-20 20:49:54 UTC
Similar problem has been detected:

Every time I restart my computer the packagekitd crashes.   

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=f28405fdc9964c58846648040dd46d50;i=372ecb;b=06e6e32bada94f80b4307e26f3cad593;m=6dab020;t=5b48bada83832;x=e083afa5dc8feaaa
kernel:         5.9.8-200.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 38 Tony 2020-11-20 23:28:13 UTC
I see this, too. https://bugzilla.redhat.com/show_bug.cgi?id=1900142

Comment 39 Fedora Update System 2020-11-21 01:25:33 UTC
FEDORA-2020-7699a31d2a has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-7699a31d2a

Comment 40 Fabio Valentini 2020-11-21 11:13:21 UTC
Similar problem has been detected:

This error happens after every reboot. No idea what causes it.
Cleaning the PK cache with "pkcon refresh -c -1" didn't help.

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=0e9b743cc54b46419b1ffa253b297139;i=14261e;b=652d9c5ad8f14f329f849f4f9cf02543;m=1e09d7f;t=5b49b2f128f99;x=d2dfa172c1f978b2
kernel:         5.8.18-300.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 41 Brent R Brian 2020-11-21 13:56:44 UTC
Similar problem has been detected:

reboot?

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=138effca05714cdc977e87cf125e6be4;i=227e;b=d63f5fdadf704e798fa3a90b13450f1a;m=8342b96;t=5b49e1d89fea6;x=1419ef9c0892571b
kernel:         5.9.8-200.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 42 Brent R Brian 2020-11-21 14:14:41 UTC
Similar problem has been detected:

reboot machine

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=138effca05714cdc977e87cf125e6be4;i=3c74;b=855c8e01a3af4a67b5711a966800ecf3;m=64bbd0e;t=5b49e617d3b64;x=80457223e8977739
kernel:         5.9.8-200.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 43 Fedora Update System 2020-11-22 02:15:23 UTC
FEDORA-2020-7699a31d2a has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-7699a31d2a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-7699a31d2a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 44 lievergenieten 2020-11-22 11:50:27 UTC
Similar problem has been detected:

whilst performing bleachbit

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=ab6ba3ce5a3747eab7fcad7817fdeeb7;i=150e6;b=b0aa57fedbd24bf89dcf8c712e27a020;m=10124b0e;t=5b176bcc75d93;x=1beb51d2f4777e0e
kernel:         5.8.14-300.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 45 Brent R Brian 2020-11-22 15:35:01 UTC
Similar problem has been detected:

powered up the machine

reporter:       libreport-2.14.0
backtrace_rating: 4
cgroup:         0::/system.slice/packagekit.service
cmdline:        /usr/libexec/packagekitd
crash_function: pk_dbus_get_uid
executable:     /usr/libexec/packagekitd
journald_cursor: s=d54050cc63bd4826ae0e685f16651561;i=20a0;b=4a594eae60bd41f2bfefb73f8a74c121;m=613cb6c;t=5b4aa29cd8727;x=9f3b4c42b568ee6
kernel:         5.9.8-200.fc33.x86_64
package:        PackageKit-1.2.1-1.fc33
reason:         packagekitd killed by SIGSEGV
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            0

Comment 46 Fedora Update System 2020-11-23 01:06:52 UTC
FEDORA-2020-7699a31d2a has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 47 Ladar Levison 2020-11-24 00:51:55 UTC
In my case this bug was a byproduct of a more serious issues. Namely, the display server/console was crashing. The system would be accessible via SSH, but the console become non-responsive. I never got an abrt report regarding the display server crash, just this packagekit crash (after rebooting). 

In this case Fedora 33 was running as a virtual guest, and I was triggering the bug by adding a second "head" to the QXL configuration. I could connect to both displays just fine. But when I tried to switch both virtual displays to full screen, the display server would crash. As it turns out, my monitors (1920x1200), were just a little bit too big for the default 16 mb QXL display buffer. I think two 1080p screens will barely fit within 16mib which might be why this hasn't bother more people. After significant pain, I discovered that increasing the QXL memory allotment to 32mib seems to have fixed the problem. 

It took several hours to figure this out, so I want to report it for the benefit of others, but I'm not sure where to report it. 

In a perfect world, that the display server shouldn't crash/lockup to begin at all. It's worth noting that I managed to avoid the crashed by adding "qxl.num_heads=2 qxl.modesetting=1" to the kernel params (by default the guest driver sets up 4 heads), and then logging in using the Xorg display server (instead of Wayland). This seemed to avert the crashes. (Wayland would still crash.) Unfortunately, this wasn't a fix, but was certainly support superior, as resizing the second monitor to 1920x1200  would succeed, while silently reducing the resolution. This happened with both the Gnome control panel and with xrandr. It took awhile, but I finally realized that was happening because the system couldn't expand the virtual screen to 3840x1200. Why this prevented the crashing, I don't know. And of course, the system should told me this was a problem because the QXL memory buffer was too small.

Perhaps this comment can get added to virt-viewer, and in the future it will automatically resize the QXL buffer when it detects that the default 16 mib is insufficient for the current host monitors.


Note You need to log in before you can comment on or make changes to this bug.