Bug 1836325 - Deploying a container image creates it's own application over previously selected application
Summary: Deploying a container image creates it's own application over previously sele...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-15 16:01 UTC by Jeff Phillips
Modified: 2020-07-13 17:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Version: 4.5.0-0.nightly-2020-05-15-045750 Cluster ID: 96b9a021-5a4c-4ff4-a8e7-882b2e801404 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36
Last Closed: 2020-07-13 17:39:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5460 0 None closed Bug 1836325: Fix to create deployed image in application grouping 2020-06-24 03:00:57 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:42 UTC

Description Jeff Phillips 2020-05-15 16:01:29 UTC
Description of problem:

Deploying a container image does not create the deployment in the shown application grouping.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. Create an workload with an application
2. Go to +Add -> Container Image
3. Enter the openshift/hello-openshift in image name from external registry field.
4. Select deployment as a resource type and keep the application selected and you will see it has created a different application.
5. Select the deployment config as a resource type and do not change the application and you will see that the workload is unassigned. (This is an intermittent)

Actual results:

It creates a different application when we select deployment as a resource. When we select deployment config, it creates workload unassigned. (This is an intermittent issue)


Expected results:

It should not create different application and should part of the shown application grouping.


Additional info:

Comment 3 Gajanan More 2020-05-21 05:05:32 UTC
I have validated the bugzilla on:
Build: 4.5.0-0.nightly-2020-05-20-235311
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 4 errata-xmlrpc 2020-07-13 17:39:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.