Bug 1836464 - Missing dependencies for texlive-kpathsea
Summary: Missing dependencies for texlive-kpathsea
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive-base
Version: rawhide
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-16 01:34 UTC by Orion Poplawski
Modified: 2020-06-19 01:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-19 01:45:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2020-05-16 01:34:20 UTC
Description of problem:

texlive-kpathsea owns the following symbolic links:
lrwxrwxrwx. 1 root root 7 May 14 15:14 /usr/bin/mktexfmt -> fmtutil
lrwxrwxrwx. 1 root root 8 May 14 15:14 /usr/bin/texhash -> mktexlsr

but no longer owns or requires their targets - they have moved to texlive-texlive-scripts.

Since texlive-kpathsea previously required texlive-tetex for fmtutil, it seems reasonable that it should now require texlive-texlive-scripts.  I'll make that change shortly unless you say otherwise.

Version-Release number of selected component (if applicable):
texlive-kpathsea-20200327-2.fc33

Comment 1 Orion Poplawski 2020-05-16 03:58:17 UTC
I'm afraid I'm back to a build problem that I cannot reproduce locally in mock.

+ latex dummy.tex
This is pdfTeX, Version 3.14159265-2.6-1.40.21 (TeX Live 2020) (preloaded format=latex)
 restricted \write18 enabled.
kpathsea: Running mktexfmt latex.fmt
mktexfmt: No such file or directory
I can't find the format file `latex.fmt'!

It seemed like all that was needed was to add a temporary BR on texlive-texlive-scripts to workaround the missing dep, and that fixed it for me locally.  Not sure why it is still failing in koji.

Comment 2 Fedora Admin user for bugzilla script actions 2020-06-03 02:58:03 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 3 Tom "spot" Callaway 2020-06-18 17:36:56 UTC
Is this still a valid bug?

Comment 4 Orion Poplawski 2020-06-19 01:45:54 UTC
No, it's resolved:

$ rpm -qf /usr/bin/mktexlsr
texlive-texlive-scripts-20200327-6.fc33.noarch
$ rpm -q --requires texlive-kpathsea | grep texlive-scripts
texlive-texlive-scripts


Note You need to log in before you can comment on or make changes to this bug.