Bug 183650 - http access should set User-Agent
Summary: http access should set User-Agent
Status: CLOSED DUPLICATE of bug 98617
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-02 14:58 UTC by Frank Ch. Eigler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-02 15:26:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Ch. Eigler 2006-03-02 14:58:19 UTC
Description of problem:
modsec-equipped httpd installations will reject anaconda's http installation
efforts, because it does not set a User-Agent: header in the http requests. 
This violates the "SHOULD" requirement in RFC2616 (section 14.43).

Version-Release number of selected component (if applicable):
Whatever's in FC5T3.

How reproducible:
Every time.

Comment 1 Frank Ch. Eigler 2006-03-02 15:00:15 UTC
Particularly, the blank User-Agent part occurs during the initial
base/stage2.img download.  Later on, "urlgrabber/2.9.6" properly appears in the
requests.

Comment 2 Chris Lumens 2006-03-02 15:26:16 UTC

*** This bug has been marked as a duplicate of 98617 ***


Note You need to log in before you can comment on or make changes to this bug.