Bug 183653 - bcm43xx works fine with iwconfig but not with NM
bcm43xx works fine with iwconfig but not with NM
Status: CLOSED DUPLICATE of bug 180369
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-03-02 10:15 EST by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 13:37:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (72.19 KB, text/plain)
2006-03-02 10:15 EST, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2006-03-02 10:15:21 EST
Description of problem:
I can connect to my wireless network (WEP) using the command line tools, but NM
doesn't seem to be able to connect.  Wired networking works just fine.

Version-Release number of selected component (if applicable):
NetworkManager-0.5.1-18.cvs20060301
kernel-2.6.15-1.1996_FC5

How reproducible:
Always

Steps to Reproduce:
1. Turn on my iBook
2. Get prompted for WEP key; enter it
3. Watch spinning icon ... it ends with the no connection icon
  
Actual results:
No wireless connection

Expected results:
Connect to wireless network just as I can do with iwconfig

Additional info:
See attached /var/log/messages (stripped of what I think is irrelevant information)
Comment 1 Andrew Overholt 2006-03-02 10:15:22 EST
Created attachment 125538 [details]
/var/log/messages
Comment 2 Andrew Overholt 2006-03-08 09:21:33 EST
Adding as blocker for FC5.  Feel free to remove if this isn't important enough
for a blocker.
Comment 3 Christopher Aillon 2006-03-08 13:37:14 EST

*** This bug has been marked as a duplicate of 180369 ***
Comment 4 David Woodhouse 2006-03-22 11:00:45 EST
Please try this again with the 2.6.16-1.2070 or later kernel, which has a bunch
of fixes to make bcm43xx less picky about the order in which various
initialisation functions are performed.
Comment 5 Samuel Audet 2006-07-25 14:47:30 EDT
Are those fixes that were included in verision 2.6.16-1.2070 this still valid
for kernels version 2.6.17? It seems to screw up pretty dramatically with
version 2.6.17-1.2145 and 2157 here ... I'm just wondering if those patches got
removed or otherwise went unchecked ? 
Comment 6 Andrew Overholt 2006-07-25 14:53:09 EDT
(In reply to comment #5)
> Are those fixes that were included in verision 2.6.16-1.2070 this still valid
> for kernels version 2.6.17? It seems to screw up pretty dramatically with
> version 2.6.17-1.2145 and 2157 here ... I'm just wondering if those patches got
> removed or otherwise went unchecked ? 

I actually have pretty good luck at home and work but had a terrible time at OLS
last week.  I assumed it was very touchy about APs but maybe it's something else.
Comment 7 Samuel Audet 2006-07-25 18:06:31 EDT
Ubuntu seems to have patched wpa_supplicant and NetworkManager to fix this...
https://launchpad.net/distros/ubuntu/+source/network-manager/+bug/42504

But I'm not sure what was part of this "update" that fixed their issues...

Note You need to log in before you can comment on or make changes to this bug.