Bug 1836753 - Cluster operator image-registry can't create when launch a IPI on Azure
Summary: Cluster operator image-registry can't create when launch a IPI on Azure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: ---
: 4.3.z
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
: 1836750 1847677 (view as bug list)
Depends On: 1823590
Blocks: 1808426
TreeView+ depends on / blocked
 
Reported: 2020-05-18 04:06 UTC by Wenjing Zheng
Modified: 2020-06-18 20:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: the restrictions for Azure container was backported from 4.4 Consequence: the operator cannot bootstrap the config object as it contains empty container Fix: rollback 4.4 api changes Result: empty string is a valid value for container the operator can bootstrap its config object
Clone Of:
Environment:
Last Closed: 2020-06-17 20:27:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift api pull 547 None closed Bug 1836753: Add missing preserveUnknownFields tags 2020-09-16 05:14:03 UTC
Github openshift cluster-image-registry-operator pull 564 None closed Bug 1836753: Use release-4.3 api 2020-09-16 05:14:03 UTC
Red Hat Product Errata RHBA-2020:2436 None None None 2020-06-17 20:28:16 UTC

Description Wenjing Zheng 2020-05-18 04:06:17 UTC
This bug was initially created as a copy of Bug #1812748

I am copying this bug because: 


Description of problem:
Cluster operator image-registry can't be created when launch a IPI on Azure.


Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2020-05-17-223233


How reproducible:
Always

Steps to Reproduce:
1.Lanuch a IPI on Azure
$./openshift create cluster --log-level debug(platform selects Azure)
2.Observe process of installation
Installation finished with image-registry error
3.login to cluster,and check logs of cluster-image-registry-operator pod
$oc logs deployment/cluster-image-registry-operator -c cluster-image-registry-operator


Actual results:
$oc logs deployment/cluster-image-registry-operator -c cluster-image-registry-operator
.....
E0312 03:17:18.609395      13 clusteroperator.go:95] unable to sync ClusterOperatorStatusController: config.imageregistry.operator.openshift.io "cluster" not found, requeuing
E0312 03:17:20.640480      13 controllerimagepruner.go:260] (imaeg pruner) unable to sync: unable to apply objects: failed to create object *v1beta1.CronJob, Namespace=openshift-image-registry, Name=image-pruner: config.imageregistry.operator.openshift.io "cluster" not found, requeuing
I0312 03:17:21.208549      13 bootstrap.go:47] generating registry custom resource
E0312 03:17:21.216806      13 controller.go:250] unable to sync: Config.imageregistry.operator.openshift.io "cluster" is invalid: spec.storage.azure.container: Invalid value: "": spec.storage.azure.container in body should be at least 3 chars long, requeuing



Expected results:
Cluster operator image-registry can be created successfully

Additional info:

Comment 1 Wenjing Zheng 2020-05-18 04:06:30 UTC
*** Bug 1836750 has been marked as a duplicate of this bug. ***

Comment 4 Wenjing Zheng 2020-06-01 03:31:32 UTC
Verified on 4.3.0-0.nightly-2020-05-30-012900:
$ oc get co | grep registry
image-registry                             4.3.0-0.nightly-2020-05-30-012900   True        False         False      55m

Comment 8 errata-xmlrpc 2020-06-17 20:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2436

Comment 9 Scott Dodson 2020-06-18 20:11:08 UTC
*** Bug 1847677 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.