Bug 1836775 - Network Attachment Definition Instances Page is breaking
Summary: Network Attachment Definition Instances Page is breaking
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Bipul Adhikari
QA Contact: Radim Hrazdil
URL:
Whiteboard:
: 1836091 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-18 06:15 UTC by Bipul Adhikari
Modified: 2020-07-13 17:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:39:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5474 0 None open Bug 1836775: Fix Network Attachment Definitions page breaking issue 2020-06-24 03:01:55 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:51 UTC

Description Bipul Adhikari 2020-05-18 06:15:06 UTC
Description of problem:
The Network Attachment Definition Instance Page is breaking.

Version-Release number of selected component (if applicable): 4.5


How reproducible: 1/1


Steps to Reproduce:
1. Go to Administration -> CRD -> Network Attachment Definitions
2. Click on the Instance Tab

```
Actual results:
Error Page shows up with the following error: 
TypeError: Cannot read property 'params' of undefined
    at NetworkAttachmentDefinitionsPage (http://localhost:9000/static/network-attachment-definitions-b348e163470ed1c2bea0.js:96:54)
    at renderWithHooks (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:252577:18)
    at mountIndeterminateComponent (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:254811:13)
    at beginWork$1 (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:255955:16)
    at HTMLUnknownElement.callCallback (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:237816:14)
    at Object.invokeGuardedCallbackDev (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:237866:16)
    at invokeGuardedCallback (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:237923:31)
    at beginWork$$1 (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:260686:7)
    at performUnitOfWork (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:259677:12)
    at workLoopSync (http://localhost:9000/static/vendors~main-41949ca932617e186b38.js:259654:22)
```

Expected results:


Additional info:

Comment 3 Jakub Hadvig 2020-05-19 12:38:16 UTC
*** Bug 1836091 has been marked as a duplicate of this bug. ***

Comment 4 Radim Hrazdil 2020-05-20 15:02:56 UTC
Verified in console release-4.5 branch commit: 5994c64ee529b650bae348ef78ebc23dca8db5c5

Comment 5 Radim Hrazdil 2020-05-20 15:03:27 UTC
Verified in console release-4.5 branch commit: 5994c64ee529b650bae348ef78ebc23dca8db5c5

Comment 6 errata-xmlrpc 2020-07-13 17:39:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.