Bug 1836796 - image pruner pod cannot startup with error "failed to read registry ca bundle"
Summary: image pruner pod cannot startup with error "failed to read registry ca bundle"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Image Registry
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Oleg Bulatov
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-18 07:53 UTC by Wenjing Zheng
Modified: 2020-10-02 13:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:39:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Image registry operator log (671.30 KB, text/plain)
2020-05-18 07:53 UTC, Wenjing Zheng
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-image-registry-operator pull 556 0 None closed Bug 1836796: Fix ca bundle for image-pruner 2020-10-02 14:46:20 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:39:51 UTC

Description Wenjing Zheng 2020-05-18 07:53:36 UTC
Created attachment 1689542 [details]
Image registry operator log

Description of problem:
image prune pod cannot startup with below error:
$ oc get pods
NAME                                               READY   STATUS    RESTARTS   AGE
cluster-image-registry-operator-67ffc464f8-lgldr   2/2     Running   0          3h24m
image-pruner-1589786460-w7wmm                      0/1     Error     2          18s
image-registry-6c465cbf9c-nd9v9                    1/1     Running   0          3h20m
node-ca-9p8sq                                      1/1     Running   0          3h21m
node-ca-c4kjv                                      1/1     Running   0          3h17m
node-ca-slcxr                                      1/1     Running   0          3h21m
node-ca-wmgsg                                      1/1     Running   0          3h21m
node-ca-zdhrg                                      1/1     Running   0          3h17m
$ oc logs pods/image-pruner-1589786460-w7wmm
error: failed to read registry ca bundle: read /var/run/configmaps/serviceca/service-ca.crt: is a directory

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-17-235851

How reproducible:
Always

Steps to Reproduce:
1.Check image pruner pod under openshift-image-registry namespace
2.
3.

Actual results:
Pod cannot startup

Expected results:
Pod should startup to prune images

Additional info:

Comment 3 Wenjing Zheng 2020-05-22 11:01:53 UTC
Verified with below info:
$ oc project openshift-image-registry
Now using project "openshift-image-registry" on server "https://api.qe-groupd-0522.qe.devcluster.openshift.com:6443".
-bash-4.2$ oc get pods
NAME                                               READY   STATUS      RESTARTS   AGE
cluster-image-registry-operator-7747dd7b45-nq6w4   2/2     Running     0          11h
image-pruner-1590105600-g5m8v                      0/1     Completed   0          11h
image-pruner-1590145200-hcq6f                      0/1     Completed   0          6s
image-registry-cbf4db8bf-bg9tg                     1/1     Running     0          11h
image-registry-cbf4db8bf-mjkx5                     1/1     Running     0          11h
node-ca-2gwfg                                      1/1     Running     0          11h
node-ca-8mchn                                      1/1     Running     0          11h
node-ca-bczlz                                      1/1     Running     0          11h
node-ca-bpvlv                                      1/1     Running     0          11h
node-ca-srgjp                                      1/1     Running     0          11h
node-ca-zsqt7                                      1/1     Running     0          11h
$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-05-21-135919   True        False         11h     Cluster version is 4.5.0-0.nightly-2020-05-21-135919
$ oc logs pods/image-pruner-1590105600-g5m8v
Deleted 0 objects.

Comment 4 errata-xmlrpc 2020-07-13 17:39:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.