Bug 1836807 - Update API group for eventSources
Summary: Update API group for eventSources
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.4.z
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1836805
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-18 08:31 UTC by Jaivardhan Kumar
Modified: 2020-06-23 00:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Current event sources have apiGroup "sources.eventing.knative.dev" and this will be changing to "sources.knative.dev" for ApiSeverSource/Camel/Kafka Source Consequence: Sources generated via new apiGroup maynot be recognized in topology view. Fix: Update to latest supported apiGroup Result: Sources generated via new apiGroup would be recognized in topology view.
Clone Of: 1836805
Environment:
Last Closed: 2020-06-23 00:57:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5477 None closed [release-4.4] Bug 1836807: updates apiGroup for Knative Eventing to latest supported 2020-06-16 08:01:07 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:57:39 UTC

Description Jaivardhan Kumar 2020-05-18 08:31:17 UTC
+++ This bug was initially created as a clone of Bug #1836805 +++

Description of problem:
Current event sources have apiGroup "sources.eventing.knative.dev" and this will be changing to "sources.knative.dev" for ApiSeverSource/Camel/Kafka Source

Version-Release number of selected component (if applicable): 4.4


How reproducible:


Steps to Reproduce:
1. Install Severless/Eventing Operator, create CRs for KnatveEventing
2. Check ApiGroup for EventSources ApiSeverSource/Camel/Kafka Source

Actual results: Won't be able to view EventSources in topology for eventSouces(ApiSeverSource/Camel/Kafka Source) created with new apiGroup


Expected results: Should be able to view EventSources in topology for eventSouces(ApiSeverSource/Camel/Kafka Source) created with new apiGroup


Additional info:

Comment 1 Jaivardhan Kumar 2020-05-18 08:39:05 UTC
Associated Jira https://issues.redhat.com/browse/ODC-3000

Comment 5 Gajanan More 2020-06-15 10:54:56 UTC
I have verified it on:
Build: 4.4.0-0.ci-2020-06-15-004655
Browser: Google Chrome Version 81.0.4044.129
Marking this as verified.

Comment 7 errata-xmlrpc 2020-06-23 00:57:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.