Bug 183681 - Error inserting acpi_cpufreq
Error inserting acpi_cpufreq
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 14:41 EST by Adam Bowns
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: cpuspeed-1.2.1-1.36.fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 13:21:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of bug. (36.43 KB, image/jpeg)
2006-03-02 14:58 EST, Adam Bowns
no flags Details

  None (edit)
Description Adam Bowns 2006-03-02 14:41:50 EST
Description of problem:
When booting FC5 Test 3 on VMWare Workstation 5.5.1 build-19175 I keep noticing
the following error in the start up sequence: -

FATAL: error inserting acpi_cpufreq
(/lib/modules/2.6.15-1.1996_FC5/kernel/arch/i386/kernel/cpu/cpu_freq/acpi-cpufreq.ko):
No such device.

This could be a dupe of bug 165494, but I'll let you guys be the judge of that.

How reproducible:
Every boot.

Steps to Reproduce:
1. Boot, watch the screen.
  
Actual results:
FATAL: error inserting acpi_cpufreq
(/lib/modules/2.6.15-1.1996_FC5/kernel/arch/i386/kernel/cpu/cpu_freq/acpi-cpufreq.ko):
No such device.

Expected results:
No error.

Hardware:
NEC Versa M350, Intel Celeron M.
Comment 1 Adam Bowns 2006-03-02 14:58:36 EST
Created attachment 125563 [details]
Screenshot of bug.
Comment 2 Adam Bowns 2006-03-03 08:13:56 EST
Same problem with kernel-2.6.15-1.2008_FC5 (The only difference is the kernel
version in the error message).
Comment 3 Adam Bowns 2006-03-04 06:08:20 EST
Same problem with kernel-2.6.15-1.2009.4.2_FC5 (The only difference is the kernel
version in the error message).
Comment 4 Adam Bowns 2006-03-10 16:07:40 EST
Also present with kernel-2.6.15-1.2038_FC5.
Comment 5 Dave Jones 2006-03-11 17:32:56 EST
what's the output of the /proc/acpi/processor/CPU*/throttling files ?
Comment 6 Adam Bowns 2006-03-12 17:18:06 EST
I got these results from my system which is fully up to date with the
development yum repository (kernel-2.6.15-1.2041_FC5).

cat /proc/acpi/processor/CPU0/throttling
state count:             8
active state:            T0
states:
   *T0:                  00%
    T1:                  12%
    T2:                  25%
    T3:                  37%
    T4:                  50%
    T5:                  62%
    T6:                  75%
    T7:                  87%

It's only a uniprocessor machine, so that's the only file I have. If you need
any more info I'm more than happy to provide it.
Comment 7 Dave Jones 2006-03-17 15:35:05 EST
Well, this is annoying.  By rights acpi-cpufreq should work.
The problem is we don't really know if it will work until we try and load it.

I think for FC6 I'm going to change cpuspeed so that it doesn't activate by default.
Comment 8 zingale 2006-10-25 11:04:19 EDT
I have this same problem with FC6 on a thinkpad x60 (it is an upgrade from my
previous FC5 installation).

My /proc/acpi/processor/CPU0/throttling looks the same as above for both CPU0
and CPU1
Comment 9 Alexey Bozrikov 2006-11-03 11:43:42 EST
Same behaviour on FC6 on Thinkpad T42, kernel version:
Linux bozy-nb 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006 i686 i686
i386 GNU/Linux

# cat /proc/acpi/processor/CPU/throttling 
state count:             8
active state:            T0
states:
   *T0:                  00%
    T1:                  12%
    T2:                  25%
    T3:                  37%
    T4:                  50%
    T5:                  62%
    T6:                  75%
    T7:                  87%

Another comment: when I just installed FC6 - it worked (and the frequency
control applet worked too). Problem started after update (although kernel was
NOT updated).
Comment 10 jtravnick 2006-11-25 07:57:08 EST
Have an acer aspire 3000 I did not have this problem in FC5 but when I did a
fresh install of FC6 I now do.
Comment 11 Jarod Wilson 2006-12-21 15:17:18 EST
If folks would be so kind, please retest with the latest kernel and cpuspeed
installed. There are a few updates that have been made recently, particularly to
cpuspeed, that hopefully fix some of these issues...
Comment 12 Adam Bowns 2006-12-27 04:40:37 EST
It looks like the updates have fixed the bug for me, I'm no longer seeing the
message on boot.
Comment 13 Jarod Wilson 2007-01-02 13:21:23 EST
Closing, based on comment #12.

Note You need to log in before you can comment on or make changes to this bug.