Bug 1836938 - Wrong serverName for certificate on /metrics endpoint
Summary: Wrong serverName for certificate on /metrics endpoint
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.4.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1818772
Blocks: 1836939
TreeView+ depends on / blocked
 
Reported: 2020-05-18 14:15 UTC by Jakub Hadvig
Modified: 2020-06-02 11:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-02 11:18:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console-operator pull 431 None closed Bug 1836938: Bump godeps to get fix from library-go#799 2020-07-09 13:27:55 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:19:09 UTC

Description Jakub Hadvig 2020-05-18 14:15:47 UTC
This bug was initially created as a copy of Bug #1818772

I am copying this bug because: 



Description of problem:
/metrics endpoint cannot be scraped by prometheus due to incorrect serverName in TLS cert.

Version-Release number of selected component (if applicable):
4.5

How reproducible:
often

Steps to Reproduce:
1. Start a cluster
2. Go to prometheus targets page
3. Scroll to openshift-console-operator/console-operator/0

Actual results:
Target is down due to:
Get https://10.128.0.32:8443/metrics: x509: certificate is valid for localhost, not metrics.openshift-console-operator.svc

Expected results:
Target is up

Additional info:

Comment 3 shahan 2020-05-26 04:04:29 UTC
Goto https://prometheus-**/targets page, check console /metrics endpoint
Endpoint	
https://10.128.0.35:8443/metrics
State	
UP

4.4.0-0.nightly-2020-05-25-115719

Comment 5 errata-xmlrpc 2020-06-02 11:18:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.