Bug 18371 - apmd fails to resume Thinkpad 600E after suspend
apmd fails to resume Thinkpad 600E after suspend
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 21:04 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 17:38:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-04 21:04:38 EDT
apmd will suspend my thinkpad correctly, but I have yet to see a valid
resume.  I get back to the screen in the state that I suspended from, but
the machine does not respond to mouse or keyboard input.  The power button
does work, so some functionality remains.

I have removed all PCMCIA devices, unloaded sound modules from the kernel
(this was an issue for alsasound, so I tried it), even switched to a
virtual terminal before shutting down.  Nothing alters the outcome.  The
machine suspends quite happily, but locks up sometime during the resume
event.

I am willing to actively assist in the resolution of this bug so if someone
can inform me what info I need to be logging I will do so and return the
results ASAP.

Regards,
Ross
Comment 1 Bernhard Rosenkraenzer 2000-10-05 06:04:15 EDT
Are you running X while this is happening?
If so, does setting CHANGETTY in /etc/sysconfig/apmd help?

If this doesn't help, let's try to see if apmd is getting the resume event at
all (may as well be an interoperability issue between the kernel and your BIOS;
it probably is, since I'm not having any problems with a Gericom 3xC) - in
/etc/sysconfig/apm-scripts/apmscript, locate the line saying

"resume)" (Should be line 83 or somewhere near).

Add "touch /tmp/apmd_resume_running" after that line.
Suspend, resume, and let me know if this created the file
/tmp/apmd_resume_running.
Comment 2 keithu@parl.clemson.edu 2000-10-06 13:57:10 EDT
My Thinkpad 600E works fine (suspend and resume).  Well, mostly.  I do have the
issue that my default route disappears after a suspend and resume cycle.
Comment 3 Need Real Name 2000-10-06 15:00:15 EDT
I set CHANGETTY, but it still does not return on resume.

As for the other suggestion, my apmscript now looks like this:

...snip...
    resume)
	touch /tmp/apmd_resume_running
	# If HDPARM_AT_RESUME is set, the user has a broken disk.
...snip...

but the file apmd_resume_running is not created.

As for the other guy's success, well...
Comment 4 Bernhard Rosenkraenzer 2000-10-07 04:07:47 EDT
ross_bagley@email.com: This seems to be a bug in your BIOS - The fact that the
file isn't created shows apmd isn't invoked after the resume at all.
Try updating your BIOS.

keithu@parl.clemson.edu: Which type of network are you using when the default
route disappears? PCMCIA network? PPP?
Comment 5 keithu@parl.clemson.edu 2000-10-07 10:33:07 EDT
I have a 3Com PCMCIA 3CCFEM556 (10/100 ethernet, 56K modem).  The ethernet
configuration is a static configuration (I have a switch port for it in my
office).  It uses the 3c574_cs driver.  I have the ethernet up, pull the cable,
still have the route.  Close the lid, it suspends.  Open the lid, it comes back
up with the IP address configured, the net route configured, but the default
route missing.
Comment 6 Bernhard Rosenkraenzer 2000-10-11 09:04:19 EDT
If you remove the network card and put it back in, is the default route set?
Comment 7 keithu@parl.clemson.edu 2000-10-19 15:42:45 EDT
Ok, that's odd.  I was just experimenting with it and it seems to work.  I have
a theory that the problem is related to another problem that I have.  It seems
that usernet does not manage to kill off all of the ppp related tasks when you
stop a ppp interface.  So, if you leave the phone line connected, the interface
restarts itself after you have stopped it.  Also, if that process is running
(/sbin/ppp-watch), it would seem that it periodically kills off your default
route through eth0.  (had that happen the other day.)
Comment 8 Need Real Name 2000-10-19 17:38:13 EDT
Finally managed to find a floppy drive and update the bios.  Resume & suspend
work just fine now.  Do not try to use the CHANGEVT parameter in
/etc/sysconfig/apmd as it causes X to crash out permanently on restart (learned
the obvious way).

I'll leave the bug as needinfo so that the other discussion can continue and let
you guys close it out whenever you complete the discussion.  Although, given the
new info, it may make sense to create a new bug report for that issue and close
this one as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.