Bug 1837103 - Etcd service deletion destabilized boostrapping and CI
Summary: Etcd service deletion destabilized boostrapping and CI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.5.0
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-18 20:15 UTC by Dan Mace
Modified: 2020-07-13 17:40 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:39:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-etcd-operator pull 351 0 None closed Bug 1837103: Revert "remove dead host-etcd-2 service" 2020-06-24 03:05:58 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:17 UTC

Description Dan Mace 2020-05-18 20:15:59 UTC
Description of problem:

https://github.com/openshift/cluster-etcd-operator/pull/346 destabilized boostrapping in away that has a significant CI impact.

https://testgrid.k8s.io/redhat-openshift-ocp-release-4.5-blocking#release-openshift-ocp-installer-e2e-aws-4.5

https://search.apps.build01.ci.devcluster.openshift.com/chart?search=BootstrapTeardown_Error&maxAge=168h&context=1&type=junit&name=&maxMatches=5&maxBytes=20971520&groupBy=job


The service deletion logic can come back once something like https://github.com/openshift/cluster-etcd-operator/pull/354 merges. Until then, the service is necessary and cannot be deleted safely without causing cluster instability.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 ge liu 2020-05-26 03:51:19 UTC
Reviewed the e2e test result, there is not abnormal CI impact, close it.

Comment 4 errata-xmlrpc 2020-07-13 17:39:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.