Bug 1837108 - vsphere ipi: [sig-network] Internal connectivity for TCP and UDP on ports 9000-9999 is allowed failing
Summary: vsphere ipi: [sig-network] Internal connectivity for TCP and UDP on ports 900...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Ricardo Carrillo Cruz
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-18 20:36 UTC by Abhinav Dahiya
Modified: 2020-07-13 17:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:39:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25023 0 None closed Bug 1837108: Use HostIP on internal connectivity test for vsphere 2020-06-24 03:07:07 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:40:17 UTC

Description Abhinav Dahiya 2020-05-18 20:36:49 UTC
Description of problem:


[sig-network] Internal connectivity for TCP and UDP on ports 9000-9999 is allowed [Suite:openshift/conformance/parallel] 

is failng on vpshere IPI with errors like

```
        {
            s: "test of [TCP: ci-op-h4pw9k0m-67021-8shx4-worker-6g8dt -> ci-op-h4pw9k0m-67021-8shx4-master-0:9000] failed, unexpected response: host and/or port param are invalid. lookup ci-op-h4pw9k0m-67021-8shx4-master-0 on 139.178.87.241:53: no such host\n",
        },
```

the test are assuming that the node names are resolvable, that assumption is not valid esp on vpshere IPI and the tests should use InternalIP on the node objects to reach out to the nodes...

Expecting the node names to resolve is excessive restriction on env like vpshere, baremetal, and therefore the tests should be updated.

Version-Release number of selected component (if applicable):


How reproducible:

this is one of the consistently failing test on vpshere ipi jobs
https://search.apps.build01.ci.devcluster.openshift.com/?search=Internal+connectivity+for+TCP+and+UDP+on+ports+9000-9999+is+allowed&maxAge=48h&context=1&type=bug%2Bjunit&name=&maxMatches=5&maxBytes=20971520&groupBy=job

Actual results:


Expected results:


Additional info:

Comment 4 errata-xmlrpc 2020-07-13 17:39:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.