Bug 183711 - docbook-utils cause wine-docs build to fail in mock
docbook-utils cause wine-docs build to fail in mock
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: elinks (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-02 18:54 EST by Andreas Bierfert
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 07:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Bierfert 2006-03-02 18:54:13 EST
When building wine-docs in fc4 mock the build always dies with:
docbook2txt winedev-guide.sgml
Using catalogs: /etc/sgml/sgml-docbook-3.1-1.0-26.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#html
Working on: /builddir/build/BUILD/wine-docs-0.9.9/en/winedev-guide.sgml
ELinks: No such file or directory
make[1]: *** [winedev-guide.txt] Error 9
make[1]: Leaving directory `/builddir/build/BUILD/wine-docs-0.9.9/en'
make: *** [en] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.71534 (%build)

With the same spec fc3 and rawhide build fine in the fe buildsys...

See e.g. my latest tries:
FC4 failed http://buildsys.fedoraproject.org/build-status/job.psp?uid=5754
FC5 worked http://buildsys.fedoraproject.org/build-status/job.psp?uid=5755
FC3 worked http://buildsys.fedoraproject.org/build-status/job.psp?uid=5753

It could be related to the ELinks stuff showing up... which does not show up in
the FC3/FC5 buildlog at all... and adding it as a BuildRequires does not do any
good either.
Comment 1 Tim Waugh 2006-03-03 04:27:27 EST
Can you reproduce this on a 'by-hand' rpmbuild run, or only in mock?  I can't
see how this can happen, looking at
/usr/share/sgml/docbook/utils-*/backends/txt.  The error message comes from elinks.
Comment 2 Andreas Bierfert 2006-03-03 04:44:35 EST
Nope... only happens in mock ... strange thing is: diff from fc4 to fc5
docbook-utils does not show that much difference ... so I have no clue...
Comment 3 Tim Waugh 2006-03-03 04:56:07 EST
You can find out what commands docbook2txt executes by changing this:

docbook2txt ...

to this:

echo 'set -x'  >/tmp/txt
cat /usr/share/sgml/docbook/utils-*/backends/txt >>/tmp/txt
jw -f docbook -b /tmp/txt ...
Comment 4 Michael Schwendt 2006-03-03 05:24:08 EST
As pointed on in bug 179852, elinks is executed as the html to text
backend. What would be interesting is "ls -la" of the current directory
after the build fails and before exiting from rpmbuild with error
condition. To see whether the html files have been created from sgml
successfully as one of the earlier steps done by docbook2txt.
Comment 5 Michael Schwendt 2006-03-03 06:46:48 EST
Andreas, Tim, the debug build job I just submitted for kicks succeeded
and built the noarch package fine this time, because I used a wrapper
script around docbook2txt. Full strace included:

http://buildsys.fedoraproject.org/logs/fedora-4-extras/5772-wine-docs-0.9.9-1.fc4/noarch/build.log
http://buildsys.fedoraproject.org/logs/fedora-4-extras/5772-wine-docs-0.9.9-1.fc4/noarch/

[...]
[pid 27154] access("/dev/stdin", F_OK)  = -1 ENOENT (No such file or directory)
[pid 27154] access("/dev/stdin", F_OK)  = -1 ENOENT (No such file or directory)
[pid 27154] access("/dev/stdin", F_OK)  = -1 ENOENT (No such file or directory)
[pid 27154] gettimeofday({1141385884, 709338}, NULL) = 0
[pid 27154] stat64("/dev/stdin", 0xffcc90e8) = -1 ENOENT (No such file or direct
ory)
[pid 27154] open("/dev/stdin", O_RDONLY|O_NOCTTY|O_LARGEFILE) = -1 ENOENT (No su
ch file or directory)
[pid 27154] open("/dev/stdin.gz", O_RDONLY|O_NOCTTY|O_LARGEFILE) = -1 ENOENT (No
 such file or directory)
[pid 27154] open("/dev/stdin", O_RDONLY|O_NOCTTY|O_LARGEFILE) = -1 ENOENT (No su
ch file or directory)
[pid 27154] open("/dev/stdin", O_RDONLY|O_NOCTTY|O_LARGEFILE) = -1 ENOENT (No su
ch file or directory)
[pid 27154] open("/dev/stdin", O_RDONLY|O_NOCTTY|O_LARGEFILE) = -1 ENOENT (No su
ch file or directory)
[pid 27154] write(2, "ELinks: ", 8ELinks: )     = 8
[pid 27154] write(2, "No such file or directory", 25No such file or directory) =
 25
[pid 27154] write(2, "\n", 1
)           = 1
[...]
Comment 6 Andreas Bierfert 2006-03-03 07:24:50 EST
Hm... interessting...

Thank you Michael for your support even after or lets say especially after my
comments on #179852! Thanks.
Comment 7 Michael Schwendt 2006-03-03 07:26:38 EST
Comparing with FC-3, it doesn't look for /dev/stdin:
http://buildsys.fedoraproject.org/logs/fedora-3-extras/5775-wine-docs-0.9.9-0.1.fc3/noarch/build.log
Comment 8 Tim Waugh 2006-03-03 08:21:02 EST
'links -dump' shouldn't require /dev/stdin,
Comment 9 Karel Zak 2006-03-27 11:30:19 EST
# strace elinks -dump
file:///usr/share/doc/elinks-0.10.3/manual-0.82-en/index.html 2>&1 | grep -c stdin
0

 rpm -q elinks
elinks-0.10.3-3.1

and if I remove /dev/stdin it still works fine.
Comment 10 Karel Zak 2006-03-27 11:33:55 EST
Well, I did my test on i386, but I don't think that something like this could be
arch specific.
Comment 11 Michael Schwendt 2006-03-27 12:48:34 EST
See bug 179852 for the background. At present, we don't know why exactly
FC4 elinks fails in the way it does. It occurs in the Fedora Extras
buildsystem chroot, not with local builds. It is not arch-specific.
And IMO, elinks is not the primary culprit either.
Comment 13 Ondrej Vasik 2007-06-19 07:46:12 EDT
Communication dead for more than one year, reported against FC4, works in FC5 ,
FC3... works with local build, I think I could close it as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.