Bug 1837156 - UI does not detect older Node maintenance CRD
Summary: UI does not detect older Node maintenance CRD
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Rastislav Wagner
QA Contact: Yanping Zhang
URL:
Whiteboard:
: 1847822 (view as bug list)
Depends On:
Blocks: 1841133
TreeView+ depends on / blocked
 
Reported: 2020-05-19 00:20 UTC by Andrew Beekhof
Modified: 2020-10-27 16:00 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: NodeMaintenance CR changed apiGroup from kubevirt.io to nodemaintenances.kubevirt.io Consequence: UI was looking only for the newer one (nodemaintenances.kubevirt.io) which caused Node Maintenance action missing if older NodeMaintenance CR was present. Fix: UI looks up for both NodeMaintenance CRs Result: Node Maintenance action is present
Clone Of:
: 1841133 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:00:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6647 0 None closed Bug 1837156: Support older node maintenance CR 2021-01-13 01:07:49 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:00:50 UTC

Description Andrew Beekhof 2020-05-19 00:20:45 UTC
Description of problem:


All kubevirt CRDs changed names between CNV 2.3 and CNV 2.4
The NMO moved from "kubevirt.io" to "nodemaintenances.kubevirt.io" (the kind stayed as "NodeMaintenance").

OCP 4.5 was updated to support "nodemaintenances.kubevirt.io" but talking to Dan K, it should not be assumed that CNV 2.3 is only supported on OCP 4.4.

Therefore OCP >= 4.5 should check for both the old and new CRD names.


Version-Release number of selected component (if applicable):

OCP 4.5

How reproducible:

100%

Steps to Reproduce:
1. Install CNV 2.3 onto OCP 4.5
2. Look for the node maintenance button
3.

Actual results:

Button not displayed

Expected results:

Button is displayed
Additional info:

Comment 3 Tomas Jelinek 2020-05-29 08:30:05 UTC
Unfortunately there was no capacity this sprint to do this. Moving to upcoming.

Comment 4 mlammon 2020-06-17 16:41:36 UTC
Actually we can remove TestBlocker since workaround is to install CNV 2.4

Comment 5 Andrew Beekhof 2020-07-22 12:35:19 UTC
Hey Jiri, is this happening in 4.6?
Folks coming from CNV will still care about this

Comment 6 Jiri Tomasek 2020-09-14 07:10:24 UTC
*** Bug 1847822 has been marked as a duplicate of this bug. ***

Comment 7 Rastislav Wagner 2020-09-16 12:06:24 UTC
PR is up for 4.6

Comment 9 Yanping Zhang 2020-09-29 01:46:21 UTC
Checked on ocp 4.6 BM cluster with payload 4.6.0-0.nightly-2020-09-27-075304。
Before install CNV 2.3 on cluster, there is no "Start maintenance" item in node/BMH action/kebab.
After install CNV 2.3 on cluster, the "Start maintenance" item shows up in node/BMH action/kebab.
The bug is fixed.

Comment 12 errata-xmlrpc 2020-10-27 16:00:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.